summaryrefslogtreecommitdiff
path: root/dev-python/cwcwidth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-09 00:04:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-09 00:04:30 +0100
commit94ead5b3c01213a82c9b72a2df165452421db42b (patch)
tree8a48ed4d21de4204607288d00e68a671bef1e8f8 /dev-python/cwcwidth
parent418459f7de9eb29d6db8b61681f39c467d9600e1 (diff)
gentoo auto-resync : 09:10:2023 - 00:04:30
Diffstat (limited to 'dev-python/cwcwidth')
-rw-r--r--dev-python/cwcwidth/Manifest2
-rw-r--r--dev-python/cwcwidth/cwcwidth-0.1.9.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/cwcwidth/Manifest b/dev-python/cwcwidth/Manifest
index 1ba978ec06a7..253844bdffa8 100644
--- a/dev-python/cwcwidth/Manifest
+++ b/dev-python/cwcwidth/Manifest
@@ -1,3 +1,5 @@
DIST cwcwidth-0.1.8.gh.tar.gz 11402 BLAKE2B 21c5425f9ead30a23dd184f671b8dbeff42189d68a5d8fd61ad1a127934529e2dca1ca1462ea62a8b7c1c051b41e6e3b44c4b8b12a325b20a2c25fab4636a243 SHA512 6e2f47928362dc36dcf7a77152390326a2e49577403c084965fc532bf827b7b05b7cdd1d4ad88263023826e73d3525c80d8578414e25bf9a3e3871c8ae1211d7
+DIST cwcwidth-0.1.9.gh.tar.gz 11472 BLAKE2B 70308dcca8ea0c5cbc76726e58ef8a8b2b4bd015411753e91370a34cb600aeb15fdddc537561b0a2e5f7338e77b6a1e2a30207cbcd92d14c60a8b8bfd87ea51f SHA512 f3911fc1a32bb3739ef81d0dfb61b47de8ab62ad26f9f3c361c458b6cb0e4000a5625969972fce09e7906fd35c7ddf7bd7f6b9bcc8efd799433282bdb326969d
EBUILD cwcwidth-0.1.8.ebuild 639 BLAKE2B cc0ab07a27c5a4ab310d9351b4b88d3bc4c20522f0b09f5e758b1a4b4deb11e1c78f62d690b686fd82f361ceffaa521e18e66a7b90ca6262ee99589d410a677e SHA512 43f1847028c8e3316c1126fda412fe8af60f04b6f7d177911b7db16a3bb407dbaa1005059ab36b6b743d55e1fcfb75e02d2d4667844727632d3790c419ace4e5
+EBUILD cwcwidth-0.1.9.ebuild 641 BLAKE2B cf11f6740584c30ffe395caee1280ee00c39b19f7092d63d543c08e325e459622bbb0d98a1b1df130b530efcc1d0ce727f8e4715e845179607060f18c9a98e74 SHA512 25cce304fd97255494ce18052bb7a1db1d3d8840abaf9679eb12ae95d04aa63629fbe06999269ba9300b4355a7addaa49714012fe02f9a11ae03d7e4d928404a
MISC metadata.xml 349 BLAKE2B e1564185d34e24bd6070ffe534ded26aee31004f72bdcb85e27b6d42d243e7db1a9db68e75a6678c9da59530457d34a8cf58be54d919d18ddc539461e03992bc SHA512 65af1da9bc2295a6395395a832288b493df2218a85d8289361c05f2b0ee1bba57a3d32edf09a6c29e691dc43e4a92b34bc8980d346e7b860c5562a238731c067
diff --git a/dev-python/cwcwidth/cwcwidth-0.1.9.ebuild b/dev-python/cwcwidth/cwcwidth-0.1.9.ebuild
new file mode 100644
index 000000000000..5ced6fcb73d9
--- /dev/null
+++ b/dev-python/cwcwidth/cwcwidth-0.1.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for wc(s)width"
+HOMEPAGE="
+ https://github.com/sebastinas/cwcwidth/
+ https://pypi.org/project/cwcwidth/
+"
+SRC_URI="
+ https://github.com/sebastinas/cwcwidth/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}