summaryrefslogtreecommitdiff
path: root/dev-python/cwcwidth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-27 09:57:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-27 09:57:18 +0100
commitc70685892bc3f0b09aea1216ff278f6095f21281 (patch)
tree4f39843e13c4d3bfd7d02fcfde9adf66af6063b0 /dev-python/cwcwidth
parent6e8f2ebdce568f2c6c7870edbb9db5324a0e300f (diff)
gentoo auto-resync : 27:10:2022 - 09:57:18
Diffstat (limited to 'dev-python/cwcwidth')
-rw-r--r--dev-python/cwcwidth/Manifest2
-rw-r--r--dev-python/cwcwidth/cwcwidth-0.1.8.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/cwcwidth/Manifest b/dev-python/cwcwidth/Manifest
index 83030e6ddf4f..4397eeb9338e 100644
--- a/dev-python/cwcwidth/Manifest
+++ b/dev-python/cwcwidth/Manifest
@@ -1,3 +1,5 @@
DIST cwcwidth-0.1.7.gh.tar.gz 11282 BLAKE2B 20be2d54aceabc02a12fadc0cdee6e53037480fcc01be3b08b0ec69ccd515cdbe91a9024ea29e6dbd0d4c927ae0a32dd7debcc07815a9f2053a9ef6a5d5a0d7b SHA512 b81b1ccdce44e8e11d55258752a20e25a76452b3f0324e6168d89a5dfce706e0dd9dd28096234fcea4c38f619a41518dd7fe249552f7e27f77d383074001e468
+DIST cwcwidth-0.1.8.gh.tar.gz 11402 BLAKE2B 21c5425f9ead30a23dd184f671b8dbeff42189d68a5d8fd61ad1a127934529e2dca1ca1462ea62a8b7c1c051b41e6e3b44c4b8b12a325b20a2c25fab4636a243 SHA512 6e2f47928362dc36dcf7a77152390326a2e49577403c084965fc532bf827b7b05b7cdd1d4ad88263023826e73d3525c80d8578414e25bf9a3e3871c8ae1211d7
EBUILD cwcwidth-0.1.7.ebuild 616 BLAKE2B 02de2b540ac876120fcaf6885328724248a7078182f1349fdeb4762ae51f7660203a01f1029740c64d95ce576cf0a0d4b24e37caeab5312f4894e1a517c87dca SHA512 c06bb527dda61e542d91f265b255e1d527b13c24fb3dbdbd9f1635caba1e269a9656c1bad25d72ab54c9859e968084ebe7dfb51026a6dd378bbefe37be0d0b75
+EBUILD cwcwidth-0.1.8.ebuild 624 BLAKE2B 797238bf0cf15e56de3d6f3181a9c40a072809ce4121e527c7cd1e34871f19a23c3106e8126e96663bd253151a5def1398eba6c93d1764fc713ab1b25c54a8f6 SHA512 18bb1a5eb727298aa4c3c684766130230e746aaa0d0e6f50a00a5533fc01cca3cdf7548e19cc03f6b9013334eaa9682fdd77cfed5890521395b2ec3bd2898db1
MISC metadata.xml 349 BLAKE2B e1564185d34e24bd6070ffe534ded26aee31004f72bdcb85e27b6d42d243e7db1a9db68e75a6678c9da59530457d34a8cf58be54d919d18ddc539461e03992bc SHA512 65af1da9bc2295a6395395a832288b493df2218a85d8289361c05f2b0ee1bba57a3d32edf09a6c29e691dc43e4a92b34bc8980d346e7b860c5562a238731c067
diff --git a/dev-python/cwcwidth/cwcwidth-0.1.8.ebuild b/dev-python/cwcwidth/cwcwidth-0.1.8.ebuild
new file mode 100644
index 000000000000..a2a78e8f2f99
--- /dev/null
+++ b/dev-python/cwcwidth/cwcwidth-0.1.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for wc(s)width"
+HOMEPAGE="
+ https://github.com/sebastinas/cwcwidth/
+ https://pypi.org/project/cwcwidth/
+"
+SRC_URI="
+ https://github.com/sebastinas/cwcwidth/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}