summaryrefslogtreecommitdiff
path: root/dev-python/daemonize/daemonize-2.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /dev-python/daemonize/daemonize-2.5.0.ebuild
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'dev-python/daemonize/daemonize-2.5.0.ebuild')
-rw-r--r--dev-python/daemonize/daemonize-2.5.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/daemonize/daemonize-2.5.0.ebuild b/dev-python/daemonize/daemonize-2.5.0.ebuild
new file mode 100644
index 000000000000..8a120a67f65c
--- /dev/null
+++ b/dev-python/daemonize/daemonize-2.5.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for writing system daemons in Python"
+HOMEPAGE="https://github.com/thesharp/daemonize"
+SRC_URI="https://github.com/thesharp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"