summaryrefslogtreecommitdiff
path: root/dev-python/dap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/dap
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/dap')
-rw-r--r--dev-python/dap/Manifest3
-rw-r--r--dev-python/dap/dap-2.2.6.7-r1.ebuild34
-rw-r--r--dev-python/dap/metadata.xml23
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/dap/Manifest b/dev-python/dap/Manifest
new file mode 100644
index 000000000000..a80260b1e9d1
--- /dev/null
+++ b/dev-python/dap/Manifest
@@ -0,0 +1,3 @@
+DIST dap-2.2.6.7.tar.gz 54055 BLAKE2B 390893117a0fb2c67a1b809f71fdb470653033d145d6ca9aec0845e0ffe263582f5cde164aadaa5d188987c9dc792e499e3627a1a003372056d56c99dc9953aa SHA512 8b9ee3fbbe15777f050f067be29a8d4e8e8b58aa8b430f69330da262593808838c8e0b3946a6f7932dc5d4d1b9dad12be73b98f82a6c399f7383f2630ad6ce47
+EBUILD dap-2.2.6.7-r1.ebuild 916 BLAKE2B 0c2f186856134928d36e423f2ff7da84d6fab337e43f260d2dbb42abfd5348b4c80e098a1d4fe2b05700e656dfdbc3ce5e61d254e3b2f0a8a1f0d236dfb45b2f SHA512 2e13e68356eabab54ddf5b0d9bf9b6e3a44129ff54bbaad2fff571a129b20cb456c1270fddf82dc8e6c8eaa3fb854f1836cf0d003cabbe07e7085bc329c99e07
+MISC metadata.xml 787 BLAKE2B 68a204a85b0df24ebbbbf87ee70c1eaddbff4fdedb4deb09dd055dc803d922b10b83a4fe9630601b2310c6c423ed8fc62d7978a9290f525c105a98d8c1b13114 SHA512 5a3c57d7c7fdfaec93ce83540af0ef579edef170224913af1cb345c88958f58d5af4f8b273eb2bac024290531ac92b7bcaaee17c7bf5f8005c48d1e1a75bd0cd
diff --git a/dev-python/dap/dap-2.2.6.7-r1.ebuild b/dev-python/dap/dap-2.2.6.7-r1.ebuild
new file mode 100644
index 000000000000..3a4577fa507a
--- /dev/null
+++ b/dev-python/dap/dap-2.2.6.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Data Access Protocol client and server"
+HOMEPAGE="http://pydap.org https://pypi.org/project/dap/ https://pypi.org/project/Pydap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="server"
+
+RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]
+ server? (
+ dev-python/cheetah[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/pastescript[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/bugs docs/Changelog docs/history README TODO )
+
+src_prepare() {
+ sed -e "s/'dap.plugins'/'dap', 'dap.plugins'/" -i setup.py || die "sed failed"
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/dap/metadata.xml b/dev-python/dap/metadata.xml
new file mode 100644
index 000000000000..25a2f22e3d21
--- /dev/null
+++ b/dev-python/dap/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-geosciences@gentoo.org</email>
+ <name>Gentoo Geosciences Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <use>
+ <flag name="server">Enable OpenDAP server support</flag>
+ </use>
+ <longdescription lang="en">pydap is a Python implementation of the Data Access Protocol
+ a.k.a. DODS or OPeNDAP. Using pydap as a client you can access
+ hundreds of scientific datasets. You can also use it to serve your
+ data from a variety of formats.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">dap</remote-id>
+ </upstream>
+</pkgmetadata>