summaryrefslogtreecommitdiff
path: root/dev-python/dask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-python/dask
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest5
-rw-r--r--dev-python/dask/dask-2021.10.0.ebuild46
-rw-r--r--dev-python/dask/files/dask-2021.10.0-warning.patch38
-rw-r--r--dev-python/dask/metadata.xml1
4 files changed, 89 insertions, 1 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index f509d005360c..7e0724e588d2 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,3 +1,6 @@
+AUX dask-2021.10.0-warning.patch 1606 BLAKE2B 69d75601493a8702ad61e1e9411c1219a83a2251349e4112346215fa7d8f78e10ed1f4bd1f6f5ed1db14627e1b7ba24c8ebf180b9210589c27bdecdf3d94d207 SHA512 f0479c156cfc40c6501bbc4c1832abb2d36a322edce2b5827c05e7d6cea075e12c57c5f0460eeebe250ca049ad6df74eba7509a4517d654775c915391a6b6af4
+DIST dask-2021.10.0.tar.gz 3963245 BLAKE2B cfccf683a6fc3b55f2be3e62b04e733586401ab642ed2ed0a6cc6956e4179d5692fb1aa94757fceacf1b40efd7ea46b6d5f7bb5df407d0f51d2f711c1672307e SHA512 801378c1e09eeb6825603d4de8efe711c04c1d83dbd37d44a66695c1629d74e6914670015fb231b270fa61a668120358aa5cd32d4ee99096616624e8fe0905fa
DIST dask-2021.9.1.tar.gz 3794819 BLAKE2B c3ed5050581f41c4ea82ad9d1d233205f105434e5e6dcc654ba2e999b8cf105033d58ecf045d2063dabcb701cb2af6f092ecfd8435d24e5949ed2d39b54ae19e SHA512 20beca3f68c2e21d54c941049a1f352e19fcce7b5f7ecf84abf60cfb9979551a3e83938ca5439b662d35c0b64b26d726f6fea85641e737d0060c56a2e879755e
+EBUILD dask-2021.10.0.ebuild 1187 BLAKE2B 5c65f2f3a689965bca3b573752b7e4817513092fc4d3d3be11748db06397243f6d06383a980d71445a4a2dcc5b0f35ca4fa0078cc6200a2bcd5699f56c75aa26 SHA512 87e07734c39e7ec8c25d1fece22f0930275a31f13bc5d6b8637d43457a213977ec0011b71fb5be34ba1be3d3d415b200a636da546e3cc48219a54f3278d79671
EBUILD dask-2021.9.1.ebuild 1128 BLAKE2B ce410c6bcfaae7851628066a708ec30b67f2b053116414510b6d5fb0ea8ba5d63de11fbef5e676a0ed526b8317d8c050f113a98a1e436d229b64ed95af71b1df SHA512 05e2399604f87c34009c22cbef342f2104d0f12a3fa8ef7f1a05855e3056bcb09aaa394b92d85dc454f67fadb9ac40460467fc8264d806537047297e04342f86
-MISC metadata.xml 671 BLAKE2B 9445727611bd11837dbca3520feb00892d112b88fc694eced24573c93eb025a9702b2de84232cc00f53182f5ee4b30c5768b296fb3673bb6a8b4db7d0a093c40 SHA512 90cbb67c807023481b2203b1811f062edabf54cc28e59a37e8ad4db1dffa932b3e82a8ddd35e3daef83c8229352ca69777150c562d823add42b75800f3d5fe4b
+MISC metadata.xml 722 BLAKE2B f5ef083408180a71a3f997ab61bba6770b08018e3d0737a17a99827edd486c2d10fc8bf17c70c8d5a431bc40bdd685d2a6ce6e8e1784a2c1d89152b167f51648 SHA512 1e1a79bf0d919a2a7a0840e77f239b3aa3bcd57666a06f18113c39c9b075d03e380b37c2e9c96dfe8ba864a94e98fe52fc0b6b16e69009364374020729b261ef
diff --git a/dev-python/dask/dask-2021.10.0.ebuild b/dev-python/dask/dask-2021.10.0.ebuild
new file mode 100644
index 000000000000..7d45502daccd
--- /dev/null
+++ b/dev-python/dask/dask-2021.10.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/dask-2021.10.0-warning.patch
+)
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}
diff --git a/dev-python/dask/files/dask-2021.10.0-warning.patch b/dev-python/dask/files/dask-2021.10.0-warning.patch
new file mode 100644
index 000000000000..87c2ab318aee
--- /dev/null
+++ b/dev-python/dask/files/dask-2021.10.0-warning.patch
@@ -0,0 +1,38 @@
+From f59293c180f846a220762701006d25655095991f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 23 Oct 2021 09:09:29 +0200
+Subject: [PATCH] Fix test_describe_empty to work without global -Werror
+
+Fix test_describe_empty to work when the test suite is run without
+global -Werror. This is e.g. desirable for packagers who don't want
+the test suite for a fixed version to suddenly start failing due to
+DeprecationWarnings in dependencies that otherwise don't break
+the package.
+
+Since the test expects either a ValueError or a RuntimeWarning, it seems
+that the easiest way to assert for that is to inject the "error" filter
+for the scope of the call.
+---
+ dask/dataframe/tests/test_dataframe.py | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/dask/dataframe/tests/test_dataframe.py b/dask/dataframe/tests/test_dataframe.py
+index 32edb488..e0d88ba8 100644
+--- a/dask/dataframe/tests/test_dataframe.py
++++ b/dask/dataframe/tests/test_dataframe.py
+@@ -570,7 +570,11 @@ def test_describe_empty():
+ )
+
+ with pytest.raises((ValueError, RuntimeWarning)):
+- ddf_len0.describe(percentiles_method="dask").compute()
++ with warnings.catch_warnings():
++ # ensure that the warning is turned into an error since this is
++ # the easiest way to assert for exception-or-warning
++ warnings.simplefilter("error")
++ ddf_len0.describe(percentiles_method="dask").compute()
+
+ with pytest.raises(ValueError):
+ ddf_nocols.describe(percentiles_method="dask").compute()
+--
+2.33.1
+
diff --git a/dev-python/dask/metadata.xml b/dev-python/dask/metadata.xml
index d7797aa0cccb..f32992b65152 100644
--- a/dev-python/dask/metadata.xml
+++ b/dev-python/dask/metadata.xml
@@ -17,5 +17,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">dask</remote-id>
+ <remote-id type="github">dask/dask</remote-id>
</upstream>
</pkgmetadata>