summaryrefslogtreecommitdiff
path: root/dev-python/datashape
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-20 19:28:42 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-20 19:28:42 +0000
commit032a3dbb5d4ea63ec6c2ceb39c067ea6424b5792 (patch)
treed46be9dbc767750a192f7a4d505757f2eec582f3 /dev-python/datashape
parent6ec19c7f1bc4aa70e5f8a86cd29d579a95d97035 (diff)
gentoo resync : 20.01.2020
Diffstat (limited to 'dev-python/datashape')
-rw-r--r--dev-python/datashape/Manifest1
-rw-r--r--dev-python/datashape/datashape-0.5.4-r1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/datashape/Manifest b/dev-python/datashape/Manifest
index 2fa78d12556c..e3f3301b290a 100644
--- a/dev-python/datashape/Manifest
+++ b/dev-python/datashape/Manifest
@@ -1,3 +1,4 @@
DIST datashape-0.5.4.tar.gz 99343 BLAKE2B f976a565e5a099949e359b6b2de0cd9ebf0520e780fc096b1e528e54b26d13fb68a27cc86a7ae6f402837ecd76a6f889308cc79adc9579a26173fdf2f8abf234 SHA512 3640c3871e6a00ad5c9961586821c0aab94ed10e82f5c2d361707c66853025aec70793f74f057c30a7bbc58d4645791b33df2916732e703586fd6bb84e91bdfa
+EBUILD datashape-0.5.4-r1.ebuild 1176 BLAKE2B f71271bb5dea9d4d8525f1818af0d6e5b30807eeacb423406eb9137004eb3272a5cec11b1e4d266d0247f35e4f05c7a4d04196db4bcc20d14f2a6d66e3e0bf55 SHA512 35193eff51b563333d09064340a602e739fae611729cc0a71d6c4c0962e2dcd564ddf0edc34a575283d649e12f640e80a9aad047ee248ccfbb1d4fb667a26133
EBUILD datashape-0.5.4.ebuild 1180 BLAKE2B fd1b06c857a0710242647add17ee733a6cf91c6c10027b5f1acbb4080dea23f6894a3617b2eab118013d0de8ceb95b7939fe76dd97a12dfb7756a625b01e2ef9 SHA512 e909e1ce1c413db6927d4ea66c39bc7442d10a75fc18d90ac75eba3411cfd55cd7e94306581bffe89e99b72064f3b92fee5c606ee1e6127703ca112035d3027e
MISC metadata.xml 510 BLAKE2B 631f7ed8106fd090953d4969cbf687d3ed5990af3803ca8315a848c95c9d8a0a5293cc79b7428e5f8f1c5e8bec76ec18b3cff2eac4f6cef8ab316cc28cc0d185 SHA512 7216551730e65c069c1315ccaaad65434106876e4a33304b9f7214610fdda9919a44bfce6e8f4cff680976ff51ca10ab23ee11abf5987e7b25cdaeac8a174bb8
diff --git a/dev-python/datashape/datashape-0.5.4-r1.ebuild b/dev-python/datashape/datashape-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..ba87920acb00
--- /dev/null
+++ b/dev-python/datashape/datashape-0.5.4-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Language defining a data description protocol"
+HOMEPAGE="https://github.com/blaze/datashape"
+SRC_URI="https://github.com/blaze/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="
+ doc? ( ${RDEPEND} dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/'sphinx.ext.intersphinx', //" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}