summaryrefslogtreecommitdiff
path: root/dev-python/datashape
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/datashape
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/datashape')
-rw-r--r--dev-python/datashape/Manifest3
-rw-r--r--dev-python/datashape/datashape-0.5.4.ebuild49
-rw-r--r--dev-python/datashape/metadata.xml15
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/datashape/Manifest b/dev-python/datashape/Manifest
new file mode 100644
index 000000000000..a39cb20ab3dc
--- /dev/null
+++ b/dev-python/datashape/Manifest
@@ -0,0 +1,3 @@
+DIST datashape-0.5.4.tar.gz 99343 BLAKE2B f976a565e5a099949e359b6b2de0cd9ebf0520e780fc096b1e528e54b26d13fb68a27cc86a7ae6f402837ecd76a6f889308cc79adc9579a26173fdf2f8abf234 SHA512 3640c3871e6a00ad5c9961586821c0aab94ed10e82f5c2d361707c66853025aec70793f74f057c30a7bbc58d4645791b33df2916732e703586fd6bb84e91bdfa
+EBUILD datashape-0.5.4.ebuild 1164 BLAKE2B de803daf36da0c0cbf06fa91108b24ecb02a4127c0d9ad47944bde45ae3d56f694a493029d0cfbd93fa202a198c70d58bf8a1c9c69c062845b7c6eccfbb4217e SHA512 d18b18b3f2cc44f18442ee2487f8c0987b7596e901350ecd59db9669145a5befd22e6564ab946ce89d84a1e2ad5d4d9bf1eb90c278b8a30d9b5e42bbd42b8adb
+MISC metadata.xml 510 BLAKE2B 631f7ed8106fd090953d4969cbf687d3ed5990af3803ca8315a848c95c9d8a0a5293cc79b7428e5f8f1c5e8bec76ec18b3cff2eac4f6cef8ab316cc28cc0d185 SHA512 7216551730e65c069c1315ccaaad65434106876e4a33304b9f7214610fdda9919a44bfce6e8f4cff680976ff51ca10ab23ee11abf5987e7b25cdaeac8a174bb8
diff --git a/dev-python/datashape/datashape-0.5.4.ebuild b/dev-python/datashape/datashape-0.5.4.ebuild
new file mode 100644
index 000000000000..0162b78b8102
--- /dev/null
+++ b/dev-python/datashape/datashape-0.5.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Language defining a data description protocol"
+HOMEPAGE="https://github.com/blaze/datashape"
+SRC_URI="https://github.com/blaze/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="
+ doc? ( ${RDEPEND} dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/'sphinx.ext.intersphinx', //" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/datashape/metadata.xml b/dev-python/datashape/metadata.xml
new file mode 100644
index 000000000000..fa8c7de680ee
--- /dev/null
+++ b/dev-python/datashape/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ DataShape is a language for describing data. It is an extension of
+ the NumPy dtype with an emphasis on cross language support.
+</longdescription>
+ <upstream>
+ <remote-id type="github">blaze/datashape</remote-id>
+ </upstream>
+</pkgmetadata>