summaryrefslogtreecommitdiff
path: root/dev-python/defcon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/defcon
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/defcon')
-rw-r--r--dev-python/defcon/Manifest3
-rw-r--r--dev-python/defcon/defcon-0.6.0-r1.ebuild24
-rw-r--r--dev-python/defcon/defcon-0.6.0.ebuild4
3 files changed, 28 insertions, 3 deletions
diff --git a/dev-python/defcon/Manifest b/dev-python/defcon/Manifest
index 2fc1a3b1bda3..7ad79805ef25 100644
--- a/dev-python/defcon/Manifest
+++ b/dev-python/defcon/Manifest
@@ -1,3 +1,4 @@
DIST defcon-0.6.0.tar.gz 403682 BLAKE2B c85cf4f846cab3f7543dcec885221e9f828cdf56fb1a373c9d06b27a29c1ab22fc9702d2ce561af97e3d4aa3b03712538ce0b29a0042fa4a0fea6f11eacba69b SHA512 b981c87d2355dc83b5da0ea4879707336ade8ea4d6ca2bc13da064367938579f2a60dfa5b1c0fd3629f4a2de97676e4f02f30f99a6116049cc2a10abd13a3d7b
-EBUILD defcon-0.6.0.ebuild 560 BLAKE2B d1ce0337f8a42444fa772fe616a5520831a9739ec8cc28218e4581e79fb6731baecbe0c65026cd35ac1c3085ee4e3e0903aaa53a773bc76c4e2e3e0fed366e09 SHA512 4e12882cf87037e7bac8231b2ba07e3de781d81c5bff86c9d0f00622ef224430302752f8d206b67805de1123b1339a1540d79a991736271a9f23ef2527e81d73
+EBUILD defcon-0.6.0-r1.ebuild 551 BLAKE2B 84e684811879d9fc9919df6accf3380ac45c8b404130cdd328baf3fbcd64fcce5fc7cafbad3dbcbb086d3da22875498f22f34e138603d7f70cfeedcb6aa21d91 SHA512 50f370257963003a55f42a9b027f9e57535f853712b2f2f40c17fcca313a0803e2e1979f7d8274268ef9d0e467c14f0903bbd24a76da028fc320ede8d1959de3
+EBUILD defcon-0.6.0.ebuild 550 BLAKE2B 8f51dddccd4986ed9c0b63cc6a5e9e5a59aa1900788710ec261eb0db1eb56c457fa64e24e8765c18bc7fac66629d48ac7d219af0d7f27b560d17f6b7e1c6ac83 SHA512 898848cd36ffcc28c34d1ebaa72e4c9383140a2a9265f6dad87a72dd5cfe38b3c682df29ca90c9644da8020e279a8df84c53928ed26873b59812f1f99f434fde
MISC metadata.xml 243 BLAKE2B f40c5d69470d5136cba32e1ea6b2351ca1842a5d83381e0bef3e063e266c64bebb9ba85e1f155010e219b136c2827c989d9adf3b2c6b2f6ca265f03339c9a7ce SHA512 640630eb9d42c319ca1da37b03a03677a3dd4e48f28ce2690b64f6e4e7d5885cfda41d439f3f9d8b009be04891b043a5b0ac6f9d43b701f65c8fcc0e0613b04a
diff --git a/dev-python/defcon/defcon-0.6.0-r1.ebuild b/dev-python/defcon/defcon-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..61979f96a84d
--- /dev/null
+++ b/dev-python/defcon/defcon-0.6.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A set of UFO based objects for use in font editing applications"
+HOMEPAGE="https://github.com/typesupply/defcon"
+SRC_URI="https://github.com/typesupply/defcon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-python/fonttools-3.31.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/defcon/defcon-0.6.0.ebuild b/dev-python/defcon/defcon-0.6.0.ebuild
index 09816db1fdac..a6e241554a79 100644
--- a/dev-python/defcon/defcon-0.6.0.ebuild
+++ b/dev-python/defcon/defcon-0.6.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
DESCRIPTION="A set of UFO based objects for use in font editing applications"