summaryrefslogtreecommitdiff
path: root/dev-python/demjson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/demjson
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/demjson')
-rw-r--r--dev-python/demjson/Manifest3
-rw-r--r--dev-python/demjson/demjson-2.2.4.ebuild35
-rw-r--r--dev-python/demjson/metadata.xml8
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/demjson/Manifest b/dev-python/demjson/Manifest
new file mode 100644
index 000000000000..3f32c3680384
--- /dev/null
+++ b/dev-python/demjson/Manifest
@@ -0,0 +1,3 @@
+DIST demjson-2.2.4.tar.gz 131457 BLAKE2B 2bd38a922d68c1a415e7258d7e1cc8b852c703df5cfcd2dbffb3936fb5b93950f2af56c0a8eb961868c1e478520bf8fc33855ecc704cd5f95e6e5b310ddb3b3d SHA512 d8a1cde062d0b062bdae29b6d79ad69fb9cc185428718a0009ccbed544ed37bd354fbb86edadb56bd98183ac8636b2edae322ed19aa5f07a7b6df668c7aa0029
+EBUILD demjson-2.2.4.ebuild 844 BLAKE2B bd50a240283b062779a1a2e0ffff3fdca0e178dd37a14385beaef2cd1feb07930487b0ba3bfebdb147407995dbe8a74c74de2c17039c98dcefc9b3e26578fb80 SHA512 5b5cac99aa29cfae2c86fdcde5f3ae306e640eb652699a7e4d83e1050a98249617f411b91e4674327e722d508cc591841cc25d1887469f51e602611612c7a823
+MISC metadata.xml 236 BLAKE2B 167eb58da19caba0e03167e2f209e118ce8a468851bca2790a0353112848fffcd72522497e5f951bf5c6eafa9691fa2a1ad980843cb4170a8194f3b8178ebe16 SHA512 0f2c2a0401b53543eac90eafdd4d11c5913be07f47b968e2892ca92c265adbd9564f02a491ff2607d7031194ba3e50c7720851537341b1541120821c487147a3
diff --git a/dev-python/demjson/demjson-2.2.4.ebuild b/dev-python/demjson/demjson-2.2.4.ebuild
new file mode 100644
index 000000000000..a31928f9ea2b
--- /dev/null
+++ b/dev-python/demjson/demjson-2.2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Encoder, decoder, and lint/validator for JSON compliant with RFC 4627"
+HOMEPAGE="http://deron.meranda.us/python/demjson/ https://pypi.org/project/demjson/"
+SRC_URI="http://deron.meranda.us/python/${PN}/dist/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ cd test
+ if python_is_python3; then
+ 2to3 -w --no-diffs test_demjson.py
+ fi
+ "${PYTHON}" test_demjson.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Docs are .txt files
+ if use doc; then
+ dodoc docs/*.txt || die "Installation of documentation failed"
+ fi
+}
diff --git a/dev-python/demjson/metadata.xml b/dev-python/demjson/metadata.xml
new file mode 100644
index 000000000000..9e5274c5b4ae
--- /dev/null
+++ b/dev-python/demjson/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+</pkgmetadata>