summaryrefslogtreecommitdiff
path: root/dev-python/deprecation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /dev-python/deprecation
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'dev-python/deprecation')
-rw-r--r--dev-python/deprecation/Manifest6
-rw-r--r--dev-python/deprecation/deprecation-2.0.6.ebuild30
-rw-r--r--dev-python/deprecation/deprecation-2.0.7.ebuild43
-rw-r--r--dev-python/deprecation/metadata.xml5
4 files changed, 83 insertions, 1 deletions
diff --git a/dev-python/deprecation/Manifest b/dev-python/deprecation/Manifest
index 886c7ee3f9f3..df12d486501f 100644
--- a/dev-python/deprecation/Manifest
+++ b/dev-python/deprecation/Manifest
@@ -1,3 +1,7 @@
DIST deprecation-1.0.1.tar.gz 9596 BLAKE2B afc4cb457ce224f120d41944e6eb71c212ef4d40d5a7c5d6d695d31bd105a4a5291daf5d3c7af0f94b58049f7e745e7e5be462495de88c48cabf5a28c22b3637 SHA512 fc35e6516e1617e2baad598a91e5d83ca95ab8a2d6a2753751d6752675de93cb44210109450a2aad9eb52b3c772a8b753c1d42ab2356c6663d2a03c4f779f086
+DIST deprecation-2.0.6.tar.gz 13381 BLAKE2B 1f21a4b8bd9293d50e9068762d4f909afe02fb1f7a8f352c5b3d5d10e0da90d122927a97cf060bec626ff8538478f83740dc1d79e050fe43dc27ade8729f26d1 SHA512 69dcf5e07cfc1c746564e03063088cce65690e2b34cffe327d59edad24f00d23cf9904089ab9ff5e67dce2b6b02ed617e53959be4a907074440ddb778576aa2f
+DIST deprecation-2.0.7.tar.gz 17077 BLAKE2B da3fb5db53f281c29e2af40335ef4038e37d133563b85d0ea795a314fd9f2d725a98c100aca338dc9ebe60bb1000476e0debcfdc9c4583108004df207cb36747 SHA512 4412e2e95f4aa4b3d5598346a6649c8d945d7401ac2d0fba3b6f6eef567403c8454ebe537e8de646903cd0c2308f48ecb949dae3015ba7617edd2fa3a26ed429
EBUILD deprecation-1.0.1.ebuild 467 BLAKE2B 223c9caae66c8830dd03170bce2a31e0afe98af0d2801efa9aff54479c93853cdf1df2e66cb71b6dcfdcf57849e2a3e8690438cdb26e4493f8cdd3806411d006 SHA512 5f90ee69bf623a018861dc4f21b26112eb84ec9613c402fe286a35b4f15f6e3e5d2ee502ec97e6590537e0e384a4e896fba64c377a28399e431eb8165c896dea
-MISC metadata.xml 427 BLAKE2B 1ca92b3053beaa34b86a67c5aeff8101054ccd29889999682f95d18101a11c4c345740340d633d3fc4bc0f9f60d30b27b25ecb14d97723f3a330c66b639730de SHA512 c69de16cd81869a341c8113ec6b89d639a038de10b9b96e9fc2ccea0593f7e6d3fd2969618c97631c1c9fb377f48d07f62c928bdc1fe1d880eba28fe4f9e7454
+EBUILD deprecation-2.0.6.ebuild 678 BLAKE2B c2eb5be9f24b9b602adc7108ef6e3da3c30a6c92505017404c3b028f7792fe0f543723f639d6906740ac391bd3ad8c568802bb3b891883633784f6e0deaefa86 SHA512 ccf8038e987837569ab0a29c33e7cd003c4337746df961cd3e4d4271295989e905960d29764ca2cd36d7466dc0a79b487ea8716af98fd391ee3cbf6a77704ff2
+EBUILD deprecation-2.0.7.ebuild 975 BLAKE2B 9c5121d996cf07e1709e97011a207ac8208b87e257d96f8cdd15961766c8ba92eff73d55ddd9b34a3dc642ad50fe29d49a2b0ca9691eb7c26c34575c3cbdbb4f SHA512 851cefe5000af75464ce5093d43da2561afc0fd75b1688550ddb81278dddfd27f81109c54345c87faee9b6139a18aae93a92a975152316d642fc04f69814d95e
+MISC metadata.xml 635 BLAKE2B 5f363fe7d6dfea7c8e2a2d250134dab625e1b349be4f12c7438adeb6bd81ee1332762259b38a9460ad6de845152151e272a8454aeef86ad8994a0f755a8db89e SHA512 6878bae4d120e4d0db92023f5fbae1eba8a056515fe2746f34fcbc931d6cae8ca0c0d972eb91a571ad462fa140bcee15b6401dbbb96af09eadffb147ec3a826a
diff --git a/dev-python/deprecation/deprecation-2.0.6.ebuild b/dev-python/deprecation/deprecation-2.0.6.ebuild
new file mode 100644
index 000000000000..73bd41c2de64
--- /dev/null
+++ b/dev-python/deprecation/deprecation-2.0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to handle automated deprecations"
+HOMEPAGE="https://deprecation.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/deprecation/deprecation-2.0.7.ebuild b/dev-python/deprecation/deprecation-2.0.7.ebuild
new file mode 100644
index 000000000000..7b4f8a12a278
--- /dev/null
+++ b/dev-python/deprecation/deprecation-2.0.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to handle automated deprecations"
+HOMEPAGE="https://deprecation.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+python_prepare_all() {
+ sed -i "s/, 'sphinx.ext.intersphinx'//" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/deprecation/metadata.xml b/dev-python/deprecation/metadata.xml
index ff92bdf665f9..f24663f48abd 100644
--- a/dev-python/deprecation/metadata.xml
+++ b/dev-python/deprecation/metadata.xml
@@ -11,4 +11,9 @@
<longdescription lang="en">
A library to handle automated deprecations
</longdescription>
+ <upstream>
+ <remote-id type="pypi">deprecation</remote-id>
+ <remote-id type="github">briancurtin/deprecation</remote-id>
+ <bugs-to>https://github.com/briancurtin/deprecation/issues</bugs-to>
+ </upstream>
</pkgmetadata>