summaryrefslogtreecommitdiff
path: root/dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-14 11:36:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-14 11:36:24 +0000
commit3a5772102e4f2b6f9cc46f461c90970060ae0c5e (patch)
treed5aebb2508413a75408fd60bd4cb2c886b78ba89 /dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild
parentf7379fa6ffb6e47eabc62d0d832a5bcad1db9591 (diff)
gentoo auto-resync : 14:02:2024 - 11:36:23
Diffstat (limited to 'dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild')
-rw-r--r--dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild b/dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild
new file mode 100644
index 000000000000..116ec71f6081
--- /dev/null
+++ b/dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Small utility to convert a python dictionary into an XML string"
+HOMEPAGE="
+ https://github.com/delfick/python-dict2xml/
+ https://pypi.org/project/dict2xml/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/noseofyeti[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest