summaryrefslogtreecommitdiff
path: root/dev-python/dirty-equals
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-12 06:41:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-12 06:41:42 +0000
commitdc9bfd846ffa3990be92029481684342bc57218e (patch)
treee540fa073e926609e919a6c6dcfb653d000d27cb /dev-python/dirty-equals
parentf1634517e73f2faf342a366354c3e0f2edb45952 (diff)
gentoo auto-resync : 12:01:2025 - 06:41:42
Diffstat (limited to 'dev-python/dirty-equals')
-rw-r--r--dev-python/dirty-equals/Manifest2
-rw-r--r--dev-python/dirty-equals/dirty-equals-0.9.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/dirty-equals/Manifest b/dev-python/dirty-equals/Manifest
index afd9d9fe4a2b..f4520294cae0 100644
--- a/dev-python/dirty-equals/Manifest
+++ b/dev-python/dirty-equals/Manifest
@@ -1,3 +1,5 @@
DIST dirty-equals-0.8.0.gh.tar.gz 50468 BLAKE2B 5d5c58807c0ef26db80895a26b5246a0305ab55389f95d7e13586cad2adc4edd17d24905fad5e462c2bafb59cad7453b55400e4576e0f845ec75d617405f67bb SHA512 8fc6ee0eefe700c89acf5b2181e502422835a89e8f0bb771b07133bda48b804f09b18e452919c8eb7d50e579b032732edad3e9ec150cd7bc7a33a4db77d9ab5c
+DIST dirty-equals-0.9.0.gh.tar.gz 50607 BLAKE2B ec569a818b067a9162d8efefffc9cfae7a7a3ee7ebf1e3659334d4123644046d5195849a9bde0c93f29d23e32657eae2bf692376a6928a8e82044b5fe54a530d SHA512 5e0a3f465c1a0bc70292ab013e5622afdfa1150e3315cfde7cc6dfb458000cc925a9ec6c54fb93bfe287b2c497dbbadc6ebe8e100819e537c7e6769a7ce61776
EBUILD dirty-equals-0.8.0.ebuild 1112 BLAKE2B cb7f2d3ea972e79ea5d798ca5546c813c465bd67f822f829ecd09d5fc0802e9906affcb479dc11255df33ee3f9448a8c94d53df7e67456121bef592ac23d499a SHA512 75da84de32205ac5c3568e47f1663d72d2a5cccf309e54c83b9cb397a4b8febf1b7c7ba24ab2f892d3552ae4a037094b6c25db38eaec1da2d3178ab264a33a84
+EBUILD dirty-equals-0.9.0.ebuild 1119 BLAKE2B c20e820f58def61556401cc4a5eae6d610717bf357743d791b239146221de6e19802947dda74a5a6d28413510dc29041db6d4e69d88bc1553d9c7b98e3bad6b7 SHA512 038e2bb4d9c22147b1027bd0d956ee70cebb423ee976ca99b83727d3cbd70d8e5e1697a05c340a091d803440773ab9ecee40830493bc27fd314ad1916f459915
MISC metadata.xml 383 BLAKE2B 22601baf690733252965e033c617a835a8f06c17ef13ac4fa89a416252ebf09a0330912baa626f0e60b49c43ec6c31db3b25cd1a27c05a813114f45ec3a77993 SHA512 9f567ed60bab61ce20ad2c33f0e55978ac249e11e5e2c5b0348797a0fbd2ddc6767c298ade258453fa3d96b32a8be43ffad94cfa8ed4fded83c3bdb29f9cd3c3
diff --git a/dev-python/dirty-equals/dirty-equals-0.9.0.ebuild b/dev-python/dirty-equals/dirty-equals-0.9.0.ebuild
new file mode 100644
index 000000000000..594314e83c8f
--- /dev/null
+++ b/dev-python/dirty-equals/dirty-equals-0.9.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Doing dirty (but extremely useful) things with equals"
+HOMEPAGE="
+ https://dirty-equals.helpmanual.io/latest/
+ https://github.com/samuelcolvin/dirty-equals/
+ https://pypi.org/project/dirty-equals/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/dirty-equals/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2.4.2[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2021.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require unpackaged pytest-examples
+ tests/test_docs.py
+ )
+
+ if ! has_version "dev-python/pydantic[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_other.py
+ )
+ fi
+
+ local -x TZ=UTC
+ epytest "${args[@]}"
+}