summaryrefslogtreecommitdiff
path: root/dev-python/dirty-equals
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-14 11:06:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-14 11:06:13 +0100
commite000645bea7492c9f5277722c0ada7e1ee0b4833 (patch)
treea604499d25e682002ec55cc5e7d14e0c53809199 /dev-python/dirty-equals
parentbe8708090362c01c6111c4b76f1e395c14d86e00 (diff)
gentoo auto-resync : 14:08:2024 - 11:06:13
Diffstat (limited to 'dev-python/dirty-equals')
-rw-r--r--dev-python/dirty-equals/Manifest2
-rw-r--r--dev-python/dirty-equals/dirty-equals-0.8.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/dirty-equals/Manifest b/dev-python/dirty-equals/Manifest
index e91636ea094d..f2e19d2b8f1f 100644
--- a/dev-python/dirty-equals/Manifest
+++ b/dev-python/dirty-equals/Manifest
@@ -1,3 +1,5 @@
DIST dirty-equals-0.7.1.gh.tar.gz 49000 BLAKE2B 06c9a7522f1dda95ff682dc9c28207b29754d11b4afe7eeacd5439a9ae9f34ce0a2f5724703129aa90b5577f36646deafa5428120e823502aae616d57b3d8f0d SHA512 c50a15e4cee77b3db1b07ef9f7d1eb5b3ab6bed6d914ac5c9e2982f8cf9432beaecb5fd7997d46a94f405e0c932ea5a8d72f1c1d4b6dda86161c22cc772ab4d7
+DIST dirty-equals-0.8.0.gh.tar.gz 50468 BLAKE2B 5d5c58807c0ef26db80895a26b5246a0305ab55389f95d7e13586cad2adc4edd17d24905fad5e462c2bafb59cad7453b55400e4576e0f845ec75d617405f67bb SHA512 8fc6ee0eefe700c89acf5b2181e502422835a89e8f0bb771b07133bda48b804f09b18e452919c8eb7d50e579b032732edad3e9ec150cd7bc7a33a4db77d9ab5c
EBUILD dirty-equals-0.7.1.ebuild 1110 BLAKE2B 4c15515fc311222e935d4014761fab0fb45695f048fb7532073e3ae6cb79084e73619caa673ea5dd39fe84660a26eb556d6dda56000a9fe6bab248d7423d3f5c SHA512 e53b14519eeed125c4616d35c1565d0d2b865df9397b29d623944658bd72401352f06d8873330229cf916baa04c581ec9cff2717347dbf30d134b0000adaa8f4
+EBUILD dirty-equals-0.8.0.ebuild 1113 BLAKE2B 307bdc9ad80262c8991bc8469110b09dd38729e7398c6e3c7b826d6a045c61188f9b466cf22d1b6c013d6cd9b03d5420a40f64a58a566b75428dcc830cbcadab SHA512 2eee18fdf5702acc8d603075b4652cdad16ba6553f04cca15ad5028f5e1cdfd4a1d2b1dab436e4fa1aec06af03f6936aa8e65f074f047615b0305eb573da3930
MISC metadata.xml 383 BLAKE2B 22601baf690733252965e033c617a835a8f06c17ef13ac4fa89a416252ebf09a0330912baa626f0e60b49c43ec6c31db3b25cd1a27c05a813114f45ec3a77993 SHA512 9f567ed60bab61ce20ad2c33f0e55978ac249e11e5e2c5b0348797a0fbd2ddc6767c298ade258453fa3d96b32a8be43ffad94cfa8ed4fded83c3bdb29f9cd3c3
diff --git a/dev-python/dirty-equals/dirty-equals-0.8.0.ebuild b/dev-python/dirty-equals/dirty-equals-0.8.0.ebuild
new file mode 100644
index 000000000000..4ad91cb194b4
--- /dev/null
+++ b/dev-python/dirty-equals/dirty-equals-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Doing dirty (but extremely useful) things with equals"
+HOMEPAGE="
+ https://dirty-equals.helpmanual.io/latest/
+ https://github.com/samuelcolvin/dirty-equals/
+ https://pypi.org/project/dirty-equals/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/dirty-equals/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2.4.2[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2021.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require unpackaged pytest-examples
+ tests/test_docs.py
+ )
+
+ if ! has_version "dev-python/pydantic[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_other.py
+ )
+ fi
+
+ local -x TZ=UTC
+ epytest "${args[@]}"
+}