summaryrefslogtreecommitdiff
path: root/dev-python/distlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/distlib
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/distlib')
-rw-r--r--dev-python/distlib/Manifest3
-rw-r--r--dev-python/distlib/distlib-0.3.4-r1.ebuild2
-rw-r--r--dev-python/distlib/distlib-0.3.4-r2.ebuild67
3 files changed, 70 insertions, 2 deletions
diff --git a/dev-python/distlib/Manifest b/dev-python/distlib/Manifest
index f9ad92af11e1..423920c57e61 100644
--- a/dev-python/distlib/Manifest
+++ b/dev-python/distlib/Manifest
@@ -1,4 +1,5 @@
AUX distlib-0.3.2-system-pypiserver.py 1294 BLAKE2B 87d419e5d9bd90715e43a125617bf12a2eaf16d114557a56fa0c6afb0fa83468960dcfdba3a3eff2ff136c5ef12ec04e71cea2a77a886854181dcdc64aee954e SHA512 08ee2bdc55b30ba770179c97a8dc7f702d72588b6f8bfd65feb47847ee4b41b97c0f31d37e1c4cfc2cff35ccb189abfc07590a175b7d2fd592beda8eb4a8b040
DIST distlib-0.3.4.tar.bz2 1169083 BLAKE2B f1b5e5ca7d0155d204db177d9844cdff4d593be3d927bd5f9e8ad07065b52383527d3990b66c5868bb8377703d031958c5c88a9daf4f0b238903ddbea3ef6cf0 SHA512 24f8d6f5012c881ffa6bbdae7887ee5a7608ac36a83e2a96cb8a337d1ab6c896a4078028d0383165ff44be6b735aa31f7d199845d89899813be74ed00e1680e8
-EBUILD distlib-0.3.4-r1.ebuild 1456 BLAKE2B 2cd9f4ea2e630cd1e5017d3d41af803cf4760f51c44c5986cff4102d7857433be2ea1634912bef3b985d49c45cfa5a0d60b22702fd06f5842ad500594468342f SHA512 de9570b8c11e400272f2864aeecdfe919d20756c4dbfa590b981c7d070d43ce0022c3e6c7a0642f8784b4707fde88068cf238a69dbca6753bee39e76563fb0e3
+EBUILD distlib-0.3.4-r1.ebuild 1463 BLAKE2B 04c57c3b13b1403a51f26a5f14f25032d18332195f09934257d316b3911c6df2d3e55cd000bba03dd42c524e84d122b1c5ad665d5347b20db85f267ae20164b6 SHA512 d987dda00396f3049e427f79d2a455475c57598dd59e6da6c82d764a4ecf7a9f5ff27a632d6770313330b7d5cb3aa74547014df176c5a16d0c0c61342634ef32
+EBUILD distlib-0.3.4-r2.ebuild 1887 BLAKE2B 4c652f552ca9fd7267e7766c63116439f715aba8f1c78cc999311402097cd06f5bd9bb96d0257171e43f5033237ed945269363f46bddb012320fdf7ff61b2dab SHA512 b8f9c52fc9e05cef75f8e8305f3f57cf8e3dbcd9efb390afad7b4c1683ff300a83547b26c0993f53d6a6976a72fe7f0fbec1976af9df816c07ed063bc94808c0
MISC metadata.xml 313 BLAKE2B 794a344badc2cae807823fd404a78b050598fa4da29cd4d2e4e6a6303822744abb1c1bd6e60a823f9b545d851988b72300f22ed16e3d374a4dc1e251e4489dea SHA512 91ac7d65e443b8fafda593e262e198fb8dc9d38d16ef32e5b66987dfc6d3023fdca6bc06e15f766f14bbf69b9efc69a900a1876d8ca46749cd6981b2cb7567bb
diff --git a/dev-python/distlib/distlib-0.3.4-r1.ebuild b/dev-python/distlib/distlib-0.3.4-r1.ebuild
index 497ae0873e9c..4dc1127a1909 100644
--- a/dev-python/distlib/distlib-0.3.4-r1.ebuild
+++ b/dev-python/distlib/distlib-0.3.4-r1.ebuild
@@ -17,7 +17,7 @@ SRC_URI="
LICENSE="PSF-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
IUSE="test"
# This package's tests are extremely fragile and tend to break or hang
# when it doesn't like metadata of packages installed on the system.
diff --git a/dev-python/distlib/distlib-0.3.4-r2.ebuild b/dev-python/distlib/distlib-0.3.4-r2.ebuild
new file mode 100644
index 000000000000..61b526013800
--- /dev/null
+++ b/dev-python/distlib/distlib-0.3.4-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Low-level components of distutils2/packaging"
+HOMEPAGE="
+ https://pypi.org/project/distlib/
+ https://bitbucket.org/pypa/distlib/
+"
+# pypi has zip only :-(
+SRC_URI="
+ https://bitbucket.org/pypa/distlib/get/${PV}.tar.bz2 -> ${P}.tar.bz2
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pypiserver is called as external executable
+# openpyxl installs invalid metadata that breaks distlib
+BDEPEND="
+ test? (
+ dev-python/pypiserver
+ !!<dev-python/openpyxl-3.0.3[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # make sure they're not used
+ rm tests/pypi-server-standalone.py || die
+
+ # use system pypiserver instead of broken bundled one
+ eapply "${FILESDIR}"/distlib-0.3.2-system-pypiserver.py || die
+
+ # doesn't work with our patched pip
+ sed -i -e '/PIP_AVAIL/s:True:False:' tests/test_wheel.py || die
+
+ # broken with pypy3
+ sed -i -e 's:test_custom_shebang:_&:' tests/test_scripts.py || die
+ # broken with py3.11, doesn't look important
+ sed -i -e 's:test_sequencer_basic:_&:' tests/test_util.py || die
+ # https://bugs.gentoo.org/843839
+ sed -i -e 's:test_interpreter_args:_&:' tests/test_scripts.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x SKIP_ONLINE=1
+ local -x PYTHONHASHSEED=0
+
+ # disable system-site-packages -- distlib has no deps, and is very
+ # fragile to packages actually installed on the system
+ sed -i -e '/system-site-packages/s:true:false:' \
+ "${BUILD_DIR}/install${EPREFIX}/usr/bin/pyvenv.cfg" || die
+
+ "${EPYTHON}" tests/test_all.py -v -x ||
+ die "Tests failed with ${EPYTHON}"
+}