summaryrefslogtreecommitdiff
path: root/dev-python/distro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/distro
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/distro')
-rw-r--r--dev-python/distro/Manifest5
-rw-r--r--dev-python/distro/distro-1.0.2.ebuild20
-rw-r--r--dev-python/distro/distro-1.0.4.ebuild25
-rw-r--r--dev-python/distro/metadata.xml20
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/distro/Manifest b/dev-python/distro/Manifest
new file mode 100644
index 000000000000..fad14e818012
--- /dev/null
+++ b/dev-python/distro/Manifest
@@ -0,0 +1,5 @@
+DIST distro-1.0.2.tar.gz 27787 SHA256 77ec1f3695eed4dcda4e0e89d04dfcd91a20d3080d34f9294c5da47235382745 SHA512 df29ca40c1e7dd6e370396ceca684f5ce41fe50450faea104132d0e5dee05a91a525db715835c7efbca020e9c2e063bde9a6da07967eda6bfa8180856e175abb WHIRLPOOL 064c3ad4e0b82249a70dcb45d1b70ed3122209378fc83564060eeb815731b7454fa5952f794a4438a6f24b7cabfe6576c629598bc8f6f93ea2867a0f771856ee
+DIST distro-1.0.4.tar.gz 28772 SHA256 9b000b0d637bb0cbd130a7a4835681e6993e309a85564dfea9d884825fe46954 SHA512 466f2e14b169998e3ff7420e12bf270ad9f934962ae92c2d24bdd747897ad66cb348194dd1376b8b53ed298ea02039943c80d9ccc6b8a01c2bd0c6d2be82c7f6 WHIRLPOOL 61aac16fe7f4cf2ad6a28cbd45001424081dc5b931716883a7822318e06d189742651a3f7de09d7aeef1d792ffb7615dca4b3f2becd2b4f93a18fb0411467c11
+EBUILD distro-1.0.2.ebuild 464 SHA256 9f8dcbf646650773b5e7b8c005ecaa8932d32062cf4f120674f9aa184ea27bf2 SHA512 81cea1b6cd1b74144e0de8afab047065d5a7e3f61bdf5033f58c924441631294fcd2299f71a17dbed366585f59e540c6c5f3c1bd06f0c366b3d7417f8bb6b3f6 WHIRLPOOL 8f7de01592f19b420704e5320034738a80ffe77e1351bd0fbaa4fa9b7aad2ecb66567e5297be33af3413507ea915f0581b968a6ed5b0d25fe960b78757788558
+EBUILD distro-1.0.4.ebuild 584 SHA256 0d1ef62f841026e02e7fa70ea83d11c41313f3bf5c5b9e258ecba82cecbcd4e4 SHA512 d201207a85c964cf3e9f611ca57fbf7eab21301d78db413077e3f60ca072633a4c78583584fd740d0a4b186890f409df994913b3056ae535b8aee6ab8a8bf8c3 WHIRLPOOL 936b49af5382bfbffc51cd3e1697cfa19d585c47e5437957417ab503d58b60106d765035eefbac80862eb0b46bb0de6d94afabe2235d8deefeb05627f579a883
+MISC metadata.xml 813 SHA256 808db90a308e40a5eb35eb171a72df5c01de756617fbe59b373ab4b585019c65 SHA512 2d9fe5a2567f86d987d950a78d68f09ac45b1a50ff02d1f1c2849c381de1a5a2f164fd6850f427650789a0274af974e23c9b8ba7ef3b37c81ad653b3ba85e0b5 WHIRLPOOL d40657a782c3e7159d34f7cdb62bcab91928b635484177574a3ae6530ccbb93cc3fc19029d21205ea5f8287285d4c2f9413f77efa1266aadfe93b8e4577a26d5
diff --git a/dev-python/distro/distro-1.0.2.ebuild b/dev-python/distro/distro-1.0.2.ebuild
new file mode 100644
index 000000000000..eb08f5a4b8a5
--- /dev/null
+++ b/dev-python/distro/distro-1.0.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Reliable machine-readable Linux distribution information for Python"
+HOMEPAGE="http://distro.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
diff --git a/dev-python/distro/distro-1.0.4.ebuild b/dev-python/distro/distro-1.0.4.ebuild
new file mode 100644
index 000000000000..5953b7c8d536
--- /dev/null
+++ b/dev-python/distro/distro-1.0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Reliable machine-readable Linux distribution information for Python"
+HOMEPAGE="http://distro.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # incomplete test resources
+
+python_test() {
+ py.test || die
+}
diff --git a/dev-python/distro/metadata.xml b/dev-python/distro/metadata.xml
new file mode 100644
index 000000000000..ea74de39e0f3
--- /dev/null
+++ b/dev-python/distro/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ distro (for: Linux Distribution) provides information about the
+ Linux distribution it runs on, such as a reliable machine-readable
+ ID, or version information. It is a renewed alternative
+ implementation for Python's original platform.linux_distribution
+ function, but it also provides much more functionality which isn't
+ necessarily Python bound like a command-line interface.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">distro</remote-id>
+ <remote-id type="github">nir0s/distro</remote-id>
+ </upstream>
+</pkgmetadata>