summaryrefslogtreecommitdiff
path: root/dev-python/distro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-11 19:38:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-11 19:38:57 +0100
commitc650f7cf611feaa59620fd8626e78108fa3b5e51 (patch)
tree31eba3ef4db85c7cef7cfb89ee87c81e732928a9 /dev-python/distro
parent59970d0b9cd0a564851f255aebb29a9f76e39c19 (diff)
gentoo auto-resync : 11:10:2022 - 19:38:57
Diffstat (limited to 'dev-python/distro')
-rw-r--r--dev-python/distro/Manifest2
-rw-r--r--dev-python/distro/distro-1.8.0.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/distro/Manifest b/dev-python/distro/Manifest
index 169c707f3105..53b46432b747 100644
--- a/dev-python/distro/Manifest
+++ b/dev-python/distro/Manifest
@@ -1,3 +1,5 @@
DIST distro-1.7.0.tar.gz 58164 BLAKE2B 22bbd2daf9cac589530eac9a58767db6b9e389b77719516f7386a9377b49ba4c9b696165701acc42366b760b9a632c70a2243a58c12a367fef2a0a770a4aea44 SHA512 14516ecab33ee8c57c35a8279eb515fd699031fabac7d8886092ea98696797d55503179870aeb513a85e1a66c7e69f2f60bb6ea9fc935be975cb5135e1917ecc
+DIST distro-1.8.0.tar.gz 59428 BLAKE2B d1b47dd801c4414a6bb21c544c62c306a1cf49b43f70974f7a0b4bcba64620047c7d06b6507ba262eba44d2f192f654646bb69241ed5bf6b761dc9d42e049e18 SHA512 027fe8bc50e263dc49451932774f32cea7900820b6e30cc80afcdc84374777ba733137fdd8d27fec76f66ce9c579bc172721e7ae0f43e72dffbc092126b26af2
EBUILD distro-1.7.0.ebuild 604 BLAKE2B f6ea7544bbe89b785b12d3d5bd7ad1d753724fb9c3ecf8fe0838351cdb567a024424a1c6df11f563f55806ab87886e4615066308763f9a6e40d5921dbd56beda SHA512 735d94041569023a02fd97fd002cef38f647bd66e14f5a5f95f6e59db09aed82c34154c63774438e6a8bb85da5334d7b00a30c46b312b707ee66f18a43b0dc56
+EBUILD distro-1.8.0.ebuild 645 BLAKE2B 50b26eac28849e45072a75d4e825d11144e8bcbfaff1ed9faef4a83c4f78965e6f49bb984d08a9f7a9a9a5e64423bdaa7fa202cef096bc0a1c49a43d72735ce3 SHA512 007f317e2a311f0df854fde8899362be9c84e55977bc1376afd2f2d75f31032adf4725c75a82397bb9fae4482bc48fdd5e0d81efb80d7fca5e65a9f0e0033006
MISC metadata.xml 847 BLAKE2B 62f2559f30efb777b18c61efdd9c957ca1855ed90bd35c93d492225369f1b293120a3c765412b00c2efde0d2a96b6e924ffb8f5d5a2a0bf305f142d29f88a6a0 SHA512 af4a1c5373c4d2b324859e736632349214c33a6f256e2e69be4ad6a8bedf3c8adb670c187dbe16fd9a546d347639e61ac117bcf2918438f290dc8c5cdb13f89c
diff --git a/dev-python/distro/distro-1.8.0.ebuild b/dev-python/distro/distro-1.8.0.ebuild
new file mode 100644
index 000000000000..450a7bea04af
--- /dev/null
+++ b/dev-python/distro/distro-1.8.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Reliable machine-readable Linux distribution information for Python"
+HOMEPAGE="
+ https://distro.readthedocs.io/en/latest/
+ https://github.com/python-distro/distro/
+ https://pypi.org/project/distro/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest