summaryrefslogtreecommitdiff
path: root/dev-python/django-allauth/django-allauth-0.45.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-python/django-allauth/django-allauth-0.45.0.ebuild
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-python/django-allauth/django-allauth-0.45.0.ebuild')
-rw-r--r--dev-python/django-allauth/django-allauth-0.45.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/django-allauth/django-allauth-0.45.0.ebuild b/dev-python/django-allauth/django-allauth-0.45.0.ebuild
new file mode 100644
index 000000000000..acee98cb30f9
--- /dev/null
+++ b/dev-python/django-allauth/django-allauth-0.45.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Django 3rd party (social) account authentication"
+HOMEPAGE="
+ https://www.intenct.nl/projects/django-allauth/
+ https://github.com/pennersr/django-allauth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# cryptography via pyjwt[crypto]
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/python3-openid[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )"
+
+DOCS=( README.rst AUTHORS ChangeLog.rst )
+
+src_test() {
+ # cern provider tests require Internet
+ rm allauth/socialaccount/providers/cern/tests.py || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=test_settings
+ local -x PYTHONPATH=.
+ django-admin test -v 2 || die "Tests failed with ${EPYTHON}"
+}