summaryrefslogtreecommitdiff
path: root/dev-python/django-allauth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/django-allauth
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/django-allauth')
-rw-r--r--dev-python/django-allauth/Manifest2
-rw-r--r--dev-python/django-allauth/django-allauth-0.46.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/django-allauth/Manifest b/dev-python/django-allauth/Manifest
index d04f12a9891f..5f2fb5e35e0a 100644
--- a/dev-python/django-allauth/Manifest
+++ b/dev-python/django-allauth/Manifest
@@ -1,3 +1,5 @@
DIST django-allauth-0.45.0.tar.gz 581007 BLAKE2B a0f586818e4d17ece5ed009481b71c0213bf265f45d391664d411268d53124c1d5df226ca40d98722691ace5f5ed50026b0a9db3bd34070ff855059bf3e237d6 SHA512 16b166a5f97e62fef3c801af17b6b7569bd27e597cec394032a2644397afc30512f52f0ff77af8036e414086cd207dc9f5d310dbc744627b55938243ba18e50f
+DIST django-allauth-0.46.0.tar.gz 643238 BLAKE2B 91534f596e3fa2e6fa5e395bded16a793ccbec994a3099eef22980920013280f58b2204d226975c2fe7a7e2066b665789881a9bcc6d2342f70a9eb0b83c32f6c SHA512 8e89d6d6a10566e40f71845885c30c36994aef3ff9054731a7582484d12ff4c7df7903617777698e42838337ae436c41a59a318acc1d2fc0561883683f79df46
EBUILD django-allauth-0.45.0.ebuild 1127 BLAKE2B 3ca2c15f4d6895543d942e918f68696ddcdaccec0cb6ff9ef5180174f0e993bf1cbe8a7cb18a9ad7e821a8dd4ddad3e7bcebeec81b23595da09e56ad816a13d0 SHA512 4ddbd1b9e6673067ef99c2b3b1a6887659dfd11c59d62e037d023991a2e0ab2497a8a113790e742cc43b94f4c15d5e41a59852356deaf4a301cc2c6c88a5015a
+EBUILD django-allauth-0.46.0.ebuild 1127 BLAKE2B 3ca2c15f4d6895543d942e918f68696ddcdaccec0cb6ff9ef5180174f0e993bf1cbe8a7cb18a9ad7e821a8dd4ddad3e7bcebeec81b23595da09e56ad816a13d0 SHA512 4ddbd1b9e6673067ef99c2b3b1a6887659dfd11c59d62e037d023991a2e0ab2497a8a113790e742cc43b94f4c15d5e41a59852356deaf4a301cc2c6c88a5015a
MISC metadata.xml 482 BLAKE2B 67c315aa5e012ff72370a73b69ae568fc671f6e4a45001a321de2d61de81566de0170e2bac4f334502f94d89ceb61d81519aad6672be245929a0f665527e365f SHA512 b5a7c433b47e2f4f88e69b88a5ccb3220bc1eb367977e100f186edcdedd3b2575d3bf59a42fbc89e95afb8ce029f31ec32bc4c437c6778241de897073ce648ab
diff --git a/dev-python/django-allauth/django-allauth-0.46.0.ebuild b/dev-python/django-allauth/django-allauth-0.46.0.ebuild
new file mode 100644
index 000000000000..815a68413f7c
--- /dev/null
+++ b/dev-python/django-allauth/django-allauth-0.46.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Django 3rd party (social) account authentication"
+HOMEPAGE="
+ https://www.intenct.nl/projects/django-allauth/
+ https://github.com/pennersr/django-allauth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# cryptography via pyjwt[crypto]
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/python3-openid[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )"
+
+DOCS=( README.rst AUTHORS ChangeLog.rst )
+
+src_test() {
+ # cern provider tests require Internet
+ rm allauth/socialaccount/providers/cern/tests.py || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=test_settings
+ local -x PYTHONPATH=.
+ django-admin test -v 2 || die "Tests failed with ${EPYTHON}"
+}