summaryrefslogtreecommitdiff
path: root/dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:22:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:22:19 +0000
commitaa3411e241a201d53a2689766fe419f2756819f3 (patch)
treecc19adfde0a10aab1ab566c8dfe3c1616e5cc390 /dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild
parentb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (diff)
gentoo resync : 24.03.2019
Diffstat (limited to 'dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild')
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild
new file mode 100644
index 000000000000..12370642b88d
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="https://pypi.org/project/django-auth-ldap/ https://bitbucket.org/psagers/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}