summaryrefslogtreecommitdiff
path: root/dev-python/django-bootstrap5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-02 03:04:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-02 03:04:24 +0000
commit37a097af13d675b83911ac006ee9ee22d2163f9a (patch)
tree75294129093c3332ea0ba918643a3485b19550f6 /dev-python/django-bootstrap5
parentaac5e1b02ac846f5e1ce85f4f66fdec46aa9b0d1 (diff)
gentoo auto-resync : 02:11:2024 - 03:04:23
Diffstat (limited to 'dev-python/django-bootstrap5')
-rw-r--r--dev-python/django-bootstrap5/Manifest3
-rw-r--r--dev-python/django-bootstrap5/django-bootstrap5-24.3.ebuild25
-rw-r--r--dev-python/django-bootstrap5/metadata.xml15
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/django-bootstrap5/Manifest b/dev-python/django-bootstrap5/Manifest
new file mode 100644
index 000000000000..3277e70ee776
--- /dev/null
+++ b/dev-python/django-bootstrap5/Manifest
@@ -0,0 +1,3 @@
+DIST django_bootstrap5-24.3.tar.gz 54344 BLAKE2B a1a793266190eaccc44f683ce3a12ea9a6076d44498b477ba1ada5b8158bdbf4ca02fcd7db214eedb492ac1219cbf11a886107417f9571f64cb3dc68f433a8b0 SHA512 087ad0d79e1fcbd2a8506080e0d137c721572f322290969310265039ac19eee8d9e1909f421e5a4d3a6b10c669785fa9565d6d14fc7d1a31152f87f1677f2e8d
+EBUILD django-bootstrap5-24.3.ebuild 492 BLAKE2B 603d65f89c429f5295daee58d5a100e732d358923c8671d7ac700ac68cde6ed9f719b0d7fdbb88a4dfd94df581e85644c75680aa9a81c3f17da83ee505889ddb SHA512 c55820af5cfaecbe5a3312c31fd39ce01902529f984d7adba7282bf47575fcd3a5f2b2f4d0f3f419fd8eb358646baf5144621863394e67e8295f20947af5b5fc
+MISC metadata.xml 431 BLAKE2B 177707fcbc8c09dbf031266f2a09b409c8f643abe0edb28cd6cd7ded20b07d40126a068f49fd9a1d94f6c8253b97606f73cd130733325ec70e5c93426c72f6ac SHA512 1bd707febb37f49ce76561922e3adffd2cdfd3ab98521c45635883cc399ae9c3c4ab74879a3c1d8bbdadfbf148fab32884a113dfc6c69cc73e9717cde4b3acb6
diff --git a/dev-python/django-bootstrap5/django-bootstrap5-24.3.ebuild b/dev-python/django-bootstrap5/django-bootstrap5-24.3.ebuild
new file mode 100644
index 000000000000..3ba722716ceb
--- /dev/null
+++ b/dev-python/django-bootstrap5/django-bootstrap5-24.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_12 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Bootstrap 5 for Django."
+HOMEPAGE="
+ https://pypi.org/project/django-bootstrap5/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+python_test() {
+ "${EPYTHON}" -m django test tests --settings tests.app.settings \
+ || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/django-bootstrap5/metadata.xml b/dev-python/django-bootstrap5/metadata.xml
new file mode 100644
index 000000000000..1a2c1dee94bf
--- /dev/null
+++ b/dev-python/django-bootstrap5/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">django-bootstrap5</remote-id>
+ </upstream>
+</pkgmetadata>