summaryrefslogtreecommitdiff
path: root/dev-python/django-cacheops
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/django-cacheops
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/django-cacheops')
-rw-r--r--dev-python/django-cacheops/Manifest4
-rw-r--r--dev-python/django-cacheops/django-cacheops-6.1.ebuild (renamed from dev-python/django-cacheops/django-cacheops-6.0.ebuild)18
2 files changed, 16 insertions, 6 deletions
diff --git a/dev-python/django-cacheops/Manifest b/dev-python/django-cacheops/Manifest
index c89da8fa501c..f119de058c03 100644
--- a/dev-python/django-cacheops/Manifest
+++ b/dev-python/django-cacheops/Manifest
@@ -1,3 +1,3 @@
-DIST django-cacheops-6.0.tar.gz 70280 BLAKE2B 9efe5a10d86f9ad25ad67701005de962185d2c491305bb56920203718c2d5fd0b28d43f2463e28c7c00c7592a78a3adea66090b398a205d5e361dfbcf90ae887 SHA512 54ecec62ff255a867b382bb1157117c8d14d7185891aacaae33ea11283beeae2fae60659621699a52f86d536b5a582d31f24f3b00f16c2e81c1a78ea4079504e
-EBUILD django-cacheops-6.0.ebuild 1343 BLAKE2B 4fb0a485ebca18e0826ce6838cf11afb3712c13752537e95d6dc28bf4f13e20f772f940547b5babe38ce6214e7dfb29b6e07647f5bdc93156bd2a8ad279ce388 SHA512 901a88bbe46c43d767c0f68715c251c3df9b4a559f25f316da07598faaf73abc8b679c1b819611c3b5196ff397f3e0adf75f928b66eb576d6da024b1b9fe0d4e
+DIST django-cacheops-6.1.gh.tar.gz 52972 BLAKE2B bdcd045912100ebdfdfd9add23b0df634b029cc2ffe41c351176e327f1e21c90457cfca9e45348dddce60e39fee5c431428ff7f2c954194e4c06c8bc09d78945 SHA512 43dcd4f302afee1acf73125aae7c2e2eece560cc6f07f3374391ac54e0438fd59b80a24e65f52bd7aa4978fd8a428939a8d607c7aa4b25f47d68373cfc12772f
+EBUILD django-cacheops-6.1.ebuild 1524 BLAKE2B dc0dfcaaa531236a188f555a0dbe41d4ebe45827e8cc9591c2c8bc6806c5a84091a1519e0428d1cb6de4524090cfccfc3cada6bb826a6bb1d5d30b9ae8c1c931 SHA512 dd6c02284879258777c2d44423aa8d315406b1d5310ec56580f2a5fddade5dbf47ebee34331b3d0b55885b4c262e23a68a159b642a16cfe9e31abeb4d1f287ae
MISC metadata.xml 381 BLAKE2B b8bf138d65b463c15b22be44750822bf6d49f1e651ecc6884dc008b9f1c93ff314967d8d3793825e129c8ac5d98348ac2726ec36ad43b8ec5d0829a78a16a26b SHA512 ad1f2ac5abcfc3705d70cc717bc076115d299a3b973852a542a7d41fabccc695b79ada0297a48cbe8f04815d66e696b437eca896e291c7da9682a85542d3e469
diff --git a/dev-python/django-cacheops/django-cacheops-6.0.ebuild b/dev-python/django-cacheops/django-cacheops-6.1.ebuild
index ecfd5010beb1..8efce8ba040e 100644
--- a/dev-python/django-cacheops/django-cacheops-6.0.ebuild
+++ b/dev-python/django-cacheops/django-cacheops-6.1.ebuild
@@ -1,14 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
+
inherit distutils-r1
DESCRIPTION="ORM cache with automatic granular event-driven invalidation for Django"
-HOMEPAGE="https://github.com/Suor/django-cacheops"
-SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
+HOMEPAGE="
+ https://github.com/Suor/django-cacheops/
+ https://pypi.org/project/django-cacheops/
+"
+SRC_URI="
+ https://github.com/Suor/django-cacheops/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="BSD"
SLOT="0"
@@ -27,6 +35,7 @@ BDEPEND="
${RDEPEND}
dev-db/redis
dev-python/dill[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
)
"
@@ -38,6 +47,7 @@ src_prepare() {
python_test() {
local -x DJANGO_SETTINGS_MODULE=tests.settings
+ local -x PYTHONPATH=.
django-admin test -v 2 || die
}