summaryrefslogtreecommitdiff
path: root/dev-python/django-celery
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/django-celery
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/django-celery')
-rw-r--r--dev-python/django-celery/Manifest5
-rw-r--r--dev-python/django-celery/django-celery-3.1.17.ebuild56
-rw-r--r--dev-python/django-celery/metadata.xml12
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/django-celery/Manifest b/dev-python/django-celery/Manifest
new file mode 100644
index 000000000000..08d7a28305ca
--- /dev/null
+++ b/dev-python/django-celery/Manifest
@@ -0,0 +1,5 @@
+DIST django-celery-3.1.17.tar.gz 79615 SHA256 254a95b0a4386df1fd949823942f6312c80fba3c88c5efad79cad8648bc5feb5 SHA512 fa68c85ee0eea778c5921c0373f3e7547bc644cd11d83e659fdf9bf4a80e317faca12ad3941225b073609a4716c5b9574d85c5c7063cff0fdb3deb0f1b86d225 WHIRLPOOL 6f01ab8aa28723720cd2ba516c9b2ecc30c28efe69fbdc72ddb18ed0fd2cfdaede6146133ec4a59f311e223a7146a7a190eaf8d9a6d8d831e46cafe668699fff
+EBUILD django-celery-3.1.17.ebuild 1537 SHA256 8dcbac60f4241cc8becb54a14d1101f6bfe356f6dd824139829cf60b1c5719ad SHA512 51f2135366e86ccc7aeacd833f7333b2d43c3ee34c03817cfcac315bcd1d2dbf655b630afbc170a310b7c8135c0bac2b118b908846e2eaf5533c3168436d041f WHIRLPOOL 68758c09cf55768a1bd11c2d21860a8f2ebd4a1b97e73826e81ed91912966a658d73a294e2cbe08003c8690be905617976f1338b5916873086d10dad84a347ae
+MISC ChangeLog 3703 SHA256 febbab52e0ccdce14b20302bc75a714137d4dd7ea4aafc2b1fd61ad2b79584c5 SHA512 d991843cd1081c01b88aa779f8d40172ba1919bce10d11bb631bab1758d11dffd47b2c9e9603a0fd493ede63db077211cf57c96a7882533092facf53a5c60988 WHIRLPOOL 034e9dd395a5cc32003f31600bfd75af1b2880723b5812df40563e69c754786ccd33cb6de6cec9091704364cfdde3a9a9cadf62064c260e258263e8d29a38a7a
+MISC ChangeLog-2015 3770 SHA256 9cda160e3eaca3edf828e2d61d265cefa37b8877e7f6fb520981cf44b3a6e397 SHA512 acd79f68b72791120a8db4d54fe88c98fc18cf226f59d486d1b01ceeae029df37dc7a6a2cce3d6f2612e60613e6b3a7d349ccb80adf5dbeeff157c47a31d09cb WHIRLPOOL 1db84445a67651aeec553f4bc14f2948000d19070bdb21c8ae9b46a0acaed0083dd6b71d02c78fc965042b057bb2379ff0ae358dec63f00d4d81ad30fad5b1d3
+MISC metadata.xml 376 SHA256 676a2aed3ac20e4f0aa1fa772d873095fe0a7f5d01853af3e9371d8389c0f6a9 SHA512 746bbf68f1ff393ab81b45679b0052a90aea4b31752190b9d047608f626f44c4a304ab150f11a2dd86a75cd98506bb4ca61c6d499cfa94afbbbb33b0e7c1a0ce WHIRLPOOL b01a32148babce7932f2524f059c15372e8d506a6c7318ecab66813f94b74219aedc01bcbb190e9388424c6e4f765b4a86318cfe9507ab907ae3ad517238ddf5
diff --git a/dev-python/django-celery/django-celery-3.1.17.ebuild b/dev-python/django-celery/django-celery-3.1.17.ebuild
new file mode 100644
index 000000000000..3092cb13fc84
--- /dev/null
+++ b/dev-python/django-celery/django-celery-3.1.17.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Celery Integration for Django"
+HOMEPAGE="http://celeryproject.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+# Python testsuite fails when built against dev-python/django-1.8.5
+# with ValueError: save() prohibited to prevent data loss due to
+# unsaved related object 'interval'.
+
+RDEPEND="
+ >=dev-python/celery-3.1.15[${PYTHON_USEDEP}]
+ >dev-python/django-1.4[${PYTHON_USEDEP}]
+ <dev-python/django-1.9[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/django-nose[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.0[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-memcached[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-issuetracker[${PYTHON_USEDEP}]
+ dev-python/python-memcached[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # https://github.com/celery/django-celery/issues/342
+ "${PYTHON}" tests/manage.py test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/.build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/django-celery/metadata.xml b/dev-python/django-celery/metadata.xml
new file mode 100644
index 000000000000..4697f0368c48
--- /dev/null
+++ b/dev-python/django-celery/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-celery</remote-id>
+ <remote-id type="github">github/django-celery</remote-id>
+ </upstream>
+</pkgmetadata>