summaryrefslogtreecommitdiff
path: root/dev-python/django-compressor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/django-compressor
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/django-compressor')
-rw-r--r--dev-python/django-compressor/Manifest2
-rw-r--r--dev-python/django-compressor/django-compressor-2.4.1.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/django-compressor/Manifest b/dev-python/django-compressor/Manifest
index cc52824bb9c2..a05dd640a6d1 100644
--- a/dev-python/django-compressor/Manifest
+++ b/dev-python/django-compressor/Manifest
@@ -1,3 +1,5 @@
+DIST django_compressor-2.4.1.tar.gz 123800 BLAKE2B 455938c328c787e6ca48b3c413f005f9ba3cfc186587b821afb804c0de6259702060d4493e34f240bd721e547ce496a1b0de7a478eb8c9b7ac8e4ba49be755fa SHA512 d59fc8b97f9f87b26e53a9822a9b467df77449cc480a7145d7fedf020a85516dee6f3bc04519fc2e2b751134fb10ce4ddbd4ffe394b5817b973db8d90b9ccda7
DIST django_compressor-2.4.tar.gz 111853 BLAKE2B ace3796d85d654c1c22b51cdd1331e28e735659be6c724a29c722fb9aa5cf0ebeb737a3f5c43abe1f057a015689f39ff5f8ca5a28141cb7369c5ec9edb7447a1 SHA512 b4dd43ab4ad13872138c9b9be3012e2675db2131b384350c5aa13ac7859b1aa93760cc3b9c91393f51bac404eb66ae04f35b187e0b0ebacf5f0da457dd42e727
+EBUILD django-compressor-2.4.1.ebuild 835 BLAKE2B 9b277d0fe7ff922338b6d872984aaccba6e265c5bd61e5dfdbb008884970ce080a2578de829cdedf5e7b14616e87587a4df0f42bba0603b048be3a4eab8448b1 SHA512 f64287a04d3989f53b6e3a2ec8c157d48e2fcbeee232c5aa3a444d63facb832c5ee3876e6b7d715eb0f8e24bb30662325f52ece751f3923ef305228f931df1e4
EBUILD django-compressor-2.4.ebuild 598 BLAKE2B fb17efe9c83230e9a29577bed25bb920b81ed48e5b809a6a88be69f58c39de87ba9a0f3b834acf5d481a927f61180981faea01dc80a6585cc68783f7f6cae917 SHA512 0d67b2e5b39dd63f82097a38f6af5de1cc84602e7f2a0833cf7dd2eaac11e5720e489f62ee9479fbff03a7dd514209eaee409e60487062cd7a27bb8afef45c37
MISC metadata.xml 296 BLAKE2B d82279af73bd82e89d505a8270b04346e57ccfec140753496f1664d6682e8331e2d368848c0ebd3265c7dbc7c3671c19668b5dc5208d3e5bfc6ecb186ed622c8 SHA512 9eb31a231e3a4576557741c4ffdce181969ecb6f9d31b66bc5eeb2a51d43d5f03de37472a215f5241c689f9fe17711b64170c575caa131a2085f6563f7470cad
diff --git a/dev-python/django-compressor/django-compressor-2.4.1.ebuild b/dev-python/django-compressor/django-compressor-2.4.1.ebuild
new file mode 100644
index 000000000000..1d529ff01535
--- /dev/null
+++ b/dev-python/django-compressor/django-compressor-2.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Compresses linked and inline JavaScript or CSS into single cached files."
+HOMEPAGE="https://django-compressor.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+S="${WORKDIR}/${P/-/_}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+# missing test deps, package does not handle them gracefully, also seem
+# broken or whatever
+RESTRICT="test"
+
+RDEPEND="dev-python/django-appconf[${PYTHON_USEDEP}]
+ dev-python/rcssmin[${PYTHON_USEDEP}]
+ dev-python/rjsmin[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ django-admin.py test --settings=compressor.test_settings compressor ||
+ die "Tests failed with ${EPYTHON}"
+}