summaryrefslogtreecommitdiff
path: root/dev-python/django-compressor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-03 19:17:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-03 19:17:21 +0000
commit81e4fbcb846ed1cabdad699c0029b166dd7273b7 (patch)
tree16f1236b7a386949c02a6e3c13d0fcd8298fa133 /dev-python/django-compressor
parenta70f42c65202d88c203c40910fef8f96f333d1ee (diff)
gentoo resync : 03.01.2018
Diffstat (limited to 'dev-python/django-compressor')
-rw-r--r--dev-python/django-compressor/Manifest2
-rw-r--r--dev-python/django-compressor/django-compressor-1.4.ebuild61
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/django-compressor/Manifest b/dev-python/django-compressor/Manifest
index c3bd2406ec3d..914b373361ba 100644
--- a/dev-python/django-compressor/Manifest
+++ b/dev-python/django-compressor/Manifest
@@ -1,5 +1,3 @@
-DIST django-compressor-1.4.tar.gz 103414 BLAKE2B b9ba72dff76a621e47533c220175c01bd31612d53a75ced3c900201337697af254e86fb69394a12eab400f022e1a70d524467619e0ecfeace50c6552418a2f91 SHA512 620618675585248a38040d91e3c33a534758cc87c4b2cab16ac3d55f82e37be6d4d7058226f6366e14305465a29235e89acba937019cd28fe4285614797179e2
DIST django-compressor-1.5.tar.gz 105855 BLAKE2B 18cd7d664a683c44674d89f714e36dc4c7c8f9412567c12b31bc563a16340a11ffc3c4e686fa8d360a40553989ed41aa208e71aa31d0bb2c5fe31f5d7c3261e7 SHA512 d6c7a04263895a4195754a49bd4831053186c99d6fdd07977c26059eb931c982bd3b60848311e8469ad0e0298204a5fc3f0e63697a5af5608abf0b76e521c797
-EBUILD django-compressor-1.4.ebuild 1738 BLAKE2B f178727aae467c8cb9826bc8f752eb018f1d11df954856bdd7d3fb4386668ef3ca2dfb60f8079fafad77030ef8bdd77671e29a3dd015853d5b7b976fa00a441a SHA512 508d4b808189e7b4bd6b5e77b8d27ad7e989c54d2be3f6561ffed7c07f43457c4b3f26155abb35debc7262203055f14eb269b7d9031b21f0e29532b99f4053c4
EBUILD django-compressor-1.5.ebuild 1742 BLAKE2B 7489a8708c8a23d75577f48b2f28fb406c49c62cb704a3a6924afbed1b59db9d002e5db7640e35238cc261cfb2cc1ac68b5d4c5641d70b9a97ac0892af2c67dc SHA512 708665b08f576777dd3d666aa8bda2e07caadbb5c8d44f783aebe6c135d620ac4696a14630a41636fd3ef0570ec1f72fe40d947dcbc50ca8cd56aa80aaf7e867
MISC metadata.xml 339 BLAKE2B f8fd408c82c6c7f9416a7bf9092555ddcf18c962ac83a379e95ef264d8e9a09837dc6527b0bb659dfb5565887348313d5fa4ef7a28e7e91e51d3f28a1afa2bed SHA512 41051f6aacf5ae785a36c1606b2df505fd6120b9d2d9a9864ec15a5c8e72a5350b81510b5aeac28267f62310e8c192b3338001ada21c4b8fbe183f80f1043bb2
diff --git a/dev-python/django-compressor/django-compressor-1.4.ebuild b/dev-python/django-compressor/django-compressor-1.4.ebuild
deleted file mode 100644
index ddef2f2c9f7d..000000000000
--- a/dev-python/django-compressor/django-compressor-1.4.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/_}"
-
-DESCRIPTION="Compresses linked and inline javascript or CSS into a single cached file"
-HOMEPAGE="https://github.com/django-compressor/django-compressor"
-SRC_URI="https://github.com/jezdez/django_compressor/archive/${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- dev-python/django[${PYTHON_USEDEP}]
- >=dev-python/django-appconf-0.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/versiontools[${PYTHON_USEDEP}]
- test? (
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/django-discover-runner[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/Coffin[${PYTHON_USEDEP}]
- dev-python/jingo[${PYTHON_USEDEP}]
- )"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- # https://github.com/django-compressor/django-compressor/issues/531 532
- pushd "${BUILD_DIR}/lib" > /dev/null || die
- if python_is_python3; then
- sed -e s':test_cachekey:_&:' -e s':test_css:_&:g' \
- -i compressor/tests/test_base.py || die
- fi
- set -- django-admin.py test compressor --settings=compressor.test_settings
- echo "$@"
- "$@" || die "Tests failed with ${EPYTHON}"
- popd > /dev/null || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}