summaryrefslogtreecommitdiff
path: root/dev-python/django-configurations
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/django-configurations
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/django-configurations')
-rw-r--r--dev-python/django-configurations/Manifest2
-rw-r--r--dev-python/django-configurations/django-configurations-2.3.2.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/django-configurations/Manifest b/dev-python/django-configurations/Manifest
index 73ac40d69ce7..8b1cc3261e25 100644
--- a/dev-python/django-configurations/Manifest
+++ b/dev-python/django-configurations/Manifest
@@ -1,3 +1,5 @@
DIST django-configurations-2.3.1.gh.tar.gz 38288 BLAKE2B f9d4322ad3e1fe839c6cc9d3e8eee31d0f3bbd48859f8e49b5fa72a3984517b77248278c42b4a709f1a5965cff3af336c5fea7323004b41fcc15a4ee40175524 SHA512 0d3df709fe306fba1e85d03e5ce16c954a796327d857717e3e802fc717d94f7aa5255a8422e27991faaade31c29bc90e3e05923609e68893784996ca87ca93ed
+DIST django-configurations-2.3.2.gh.tar.gz 38475 BLAKE2B 2b3c583e665a08a46bc0ca0c52ae4326fbdfb794d102deecbd13f953e8b6f3fd39b3b747c591fc9717c6a0792258cdb9041de53e71db2034de1a31ddf5bfc0ea SHA512 4cb5a7b284a0025ba93b32e158fb65b57e66230938181b921a1b1264848113b697eb45ac6ad2fc4f26f3bc29ea5f77acbfd5307b20ef2d385e29c2c1746295b3
EBUILD django-configurations-2.3.1.ebuild 1148 BLAKE2B 9ac1438e97c62ad5cce48bb09a842a1b6e0ce54903bb7f036fd4f6d3f70fe96002fbcff01d0be23f5721a5e6c5da6d68b3f6593121c344d9892f628134ec6032 SHA512 b4a2ef9e292f07a1c6001d3482b4f01c4757e5f1895a1d292ba60950643f687cc3b35b3d190dd704cf00708878f86bee96ccc00d836c8d10dd24d9db6c600a6c
+EBUILD django-configurations-2.3.2.ebuild 1172 BLAKE2B 593e5055624e219cffb41e58f2c2d6f64c2965477fbf8e11eac9e21c0eb4c7142376de432b7b165e54020008107fc1a2a783e93d8f3ad2585a8384c4a9b41d2f SHA512 7866a224482f9f94924028e962559623a27c953b341407a05991584d4fbe81aed2aeedb9099a4ecb40535b75522a28b32ffb5044a468a76103568f1cba7b1693
MISC metadata.xml 219 BLAKE2B f7cf6cd41e0433b323b2c16caf31baef1c0b5ea00980018722e5fae803f92216e39343892928605454b0c756e121929eace02b4925a6bd7f10421e91a1845357 SHA512 27c6aca9eb36b7d427c10b6daedc4bc6c0d744fb464e5322ef6823073bb9be648a60ba2fff5f855282a5a5a3da3ce379d9419cde175d462f1fa443ff6b3a4bdf
diff --git a/dev-python/django-configurations/django-configurations-2.3.2.ebuild b/dev-python/django-configurations/django-configurations-2.3.2.ebuild
new file mode 100644
index 000000000000..f79518670b82
--- /dev/null
+++ b/dev-python/django-configurations/django-configurations-2.3.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A helper for organizing Django settings"
+HOMEPAGE="
+ https://pypi.org/project/django-configurations/
+ https://github.com/jazzband/django-configurations/
+ https://django-configurations.readthedocs.io/"
+SRC_URI="
+ https://github.com/jazzband/django-configurations/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/django-cache-url[${PYTHON_USEDEP}]
+ dev-python/dj-database-url[${PYTHON_USEDEP}]
+ dev-python/dj-email-url[${PYTHON_USEDEP}]
+ dev-python/dj-search-url[${PYTHON_USEDEP}]
+ )"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings.main
+ local -x DJANGO_CONFIGURATION=Test
+ PYTHONPATH=. django-cadmin test -v2 || die "Tests failed with ${EPYTHON}"
+}