summaryrefslogtreecommitdiff
path: root/dev-python/django-js-asset/django-js-asset-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-13 11:40:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-13 11:40:30 +0000
commit0ded23e9afc3d3424aef90e5cec3f2ca6d6b4c30 (patch)
tree93ef9828fae35063d273f386b2fa4a7130add56b /dev-python/django-js-asset/django-js-asset-2.2.0.ebuild
parent22b4e2ee9c8011b75d7c030d6129a7487494aeba (diff)
gentoo auto-resync : 13:12:2023 - 11:40:30
Diffstat (limited to 'dev-python/django-js-asset/django-js-asset-2.2.0.ebuild')
-rw-r--r--dev-python/django-js-asset/django-js-asset-2.2.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/django-js-asset/django-js-asset-2.2.0.ebuild b/dev-python/django-js-asset/django-js-asset-2.2.0.ebuild
new file mode 100644
index 000000000000..94a57b485d5b
--- /dev/null
+++ b/dev-python/django-js-asset/django-js-asset-2.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Script tag with additional attributes for django.forms.Media"
+HOMEPAGE="
+ https://github.com/matthiask/django-js-asset/
+ https://pypi.org/project/django-js-asset/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ cd tests || die
+ local -x DJANGO_SETTINGS_MODULE=testapp.settings
+ "${EPYTHON}" manage.py test -v 2 || die "Tests failed with ${EPYTHON}"
+}