summaryrefslogtreecommitdiff
path: root/dev-python/django-js-asset
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/django-js-asset
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/django-js-asset')
-rw-r--r--dev-python/django-js-asset/Manifest5
-rw-r--r--dev-python/django-js-asset/django-js-asset-2.0.ebuild (renamed from dev-python/django-js-asset/django-js-asset-1.2.2.ebuild)13
-rw-r--r--dev-python/django-js-asset/files/django-js-asset-1.2.2-fix-django3.patch55
3 files changed, 7 insertions, 66 deletions
diff --git a/dev-python/django-js-asset/Manifest b/dev-python/django-js-asset/Manifest
index c03fc9d52817..f15ce9295b75 100644
--- a/dev-python/django-js-asset/Manifest
+++ b/dev-python/django-js-asset/Manifest
@@ -1,4 +1,3 @@
-AUX django-js-asset-1.2.2-fix-django3.patch 1881 BLAKE2B 74ce319a395f14dbd4e3f84b8e460ebb73df733f2070b1d805014930e6030a947d77d1bc1c66b8c206c5dfaf58358ff754491ccb6a58588b9e8a52c6aa0cdad0 SHA512 a18ca46e27ddb31c836c4b7c6e1d7d449622278da0c585d2ea8a0a4d1178c5a571c1bf7ba7dc8803d291e9bf0085a22223a553d1d219bf7539288401d1c128ea
-DIST django-js-asset-1.2.2.gh.tar.gz 6367 BLAKE2B 5b24d3a2cf1ca2b28b82e581541dcb58aa2bf25d99f865007730c00211452dc5a062dc014b47fd1d10020d2a0b8f74060910460dec4f95be2b83c5c6d7bfb4d2 SHA512 ad2c51399da9b5d75305c0fa257cc75496df3f6704a827a0d297a4d762712039c3ebd921afbe6e10672626f1badd8637728292dd700ba41c4192c95ec73095a9
-EBUILD django-js-asset-1.2.2.ebuild 733 BLAKE2B 4228642154df38d83116b614399b8f726b2604f9ca8f6d99beb392a13fba771e2c796a31b6a847b410e2c15a299c129c67180181015a4b73af6bac7d7a0a9f3c SHA512 17d26ede102924fec2ea9ca1bcbfdf25983bf2d7003ad11ee0c8b2e1f3f544e36a73440a8ccb1d0a95c6b208cac7e34102985180d993149ec4745f0c8041dda1
+DIST django-js-asset-2.0.gh.tar.gz 7386 BLAKE2B 5bebddc68a6d77b9ffc4c685cfcf0c34d03a82d1f24ea0bc64f35e70bf3a736fc8be612fba1e21bfbe1cb646363f06d0d001822209e15034cb03c337c80d24fd SHA512 0ec4954952394d90946d0653e86ecf45eb83ceaeb99bfde1eeed68f471110b85260abd7ae69f5b2c318e4341c09fd31efb781825d74164dc8ac6bd94bcb6f8e7
+EBUILD django-js-asset-2.0.ebuild 754 BLAKE2B 9d9f60f072288d1ad3635d8458cb13c8783940aab5cdf12b900b248819e4c7a33c35b4f51720fc67f88f630303268d0308d7c612d7e4af85e4e50818da22b89e SHA512 aec2cd5456ef2ec33b74d5f10ec1b03ca2f30679b05b1f73bf33c7c68d89e2c88a5630226aaaf512d9341a7f99385fb34882c111f38b35e66190d8a7a773b9d3
MISC metadata.xml 246 BLAKE2B bbeaabf225f3b131a4c28d6f20d9ff944642645041d0f9a257ef05e2f1865b1c76c465b7769b7142285d25b77107999d719d73f75db841eb92b92b39d5f7a1c9 SHA512 abb5f9c6ef30b9cc55e01db0aa0093ff146eae298d3b9348226d9835b39e040b6096bc2ac7fa8ae74c55fa94e83f706ae3d2b3b755ed31c8222eb29748c0a8ac
diff --git a/dev-python/django-js-asset/django-js-asset-1.2.2.ebuild b/dev-python/django-js-asset/django-js-asset-2.0.ebuild
index 5704b6a31f05..6c706aabc246 100644
--- a/dev-python/django-js-asset/django-js-asset-1.2.2.ebuild
+++ b/dev-python/django-js-asset/django-js-asset-2.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -19,15 +20,11 @@ KEYWORDS="~amd64"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND=">=dev-python/django-1.17[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/django-2.2[${PYTHON_USEDEP}]"
BDEPEND="test? ( ${RDEPEND} )"
-PATCHES=(
- "${FILESDIR}/${P}-fix-django3.patch"
-)
-
python_test() {
cd tests || die
local -x DJANGO_SETTINGS_MODULE=testapp.settings
- django-admin test -v 2 || die
+ "${EPYTHON}" manage.py test -v 2 || die "Tests failed with ${EPYTHON}"
}
diff --git a/dev-python/django-js-asset/files/django-js-asset-1.2.2-fix-django3.patch b/dev-python/django-js-asset/files/django-js-asset-1.2.2-fix-django3.patch
deleted file mode 100644
index 4ab0484b17e0..000000000000
--- a/dev-python/django-js-asset/files/django-js-asset-1.2.2-fix-django3.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 232536ba50a2e1a0cffc6046dbcdfdec22cb0d9e Mon Sep 17 00:00:00 2001
-From: Matthias Kestenholz <mk@feinheit.ch>
-Date: Fri, 15 May 2020 08:51:33 +0200
-Subject: [PATCH] Adapt the test suite to changes in Django
-
---- a/tests/testapp/test_js_asset.py
-+++ b/tests/testapp/test_js_asset.py
-@@ -1,11 +1,15 @@
- from __future__ import unicode_literals
-
-+import django
- from django.forms import Media
- from django.test import TestCase
-
- from js_asset.js import JS
-
-
-+JS_TYPE = ' type="text/javascript"' if django.VERSION < (3, 1) else ""
-+
-+
- class AssetTest(TestCase):
- def test_asset(self):
- media = Media(
-@@ -25,15 +29,17 @@ def test_asset(self):
- html,
- )
- self.assertInHTML(
-- '<script type="text/javascript" src="/static/app/test.js"></script>', # noqa
-+ '<script{} src="/static/app/test.js"></script>'.format(JS_TYPE), # noqa
- html,
- )
- self.assertInHTML(
-- '<script type="text/javascript" src="/static/app/asset.js" data-the-answer="42" id="asset-script"></script>', # noqa
-+ '<script{} src="/static/app/asset.js" data-the-answer="42" id="asset-script"></script>'.format( # noqa
-+ JS_TYPE
-+ ),
- html,
- )
- self.assertInHTML(
-- '<script type="text/javascript" src="/static/app/asset-without.js"></script>', # noqa
-+ '<script{} src="/static/app/asset-without.js"></script>'.format(JS_TYPE),
- html,
- )
-
-@@ -42,7 +48,9 @@ def test_absolute(self):
- html = "%s" % media
-
- self.assertInHTML(
-- '<script type="text/javascript" src="https://cdn.example.org/script.js"></script>', # noqa
-+ '<script{} src="https://cdn.example.org/script.js"></script>'.format(
-+ JS_TYPE
-+ ),
- html,
- )
-