summaryrefslogtreecommitdiff
path: root/dev-python/django-nose
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/django-nose
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/django-nose')
-rw-r--r--dev-python/django-nose/Manifest3
-rw-r--r--dev-python/django-nose/django-nose-1.4.4.ebuild32
-rw-r--r--dev-python/django-nose/metadata.xml12
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/django-nose/Manifest b/dev-python/django-nose/Manifest
new file mode 100644
index 000000000000..1d02776937bd
--- /dev/null
+++ b/dev-python/django-nose/Manifest
@@ -0,0 +1,3 @@
+DIST django-nose-1.4.4.tar.gz 44266 BLAKE2B 0c2785c98350b55df332eabb534ef3a614d961fffd8f44dd9e74c55a55e298b16c4963bfb389945fe76dc7ecb1e344104a8fe4afa35219ba748a8c7aadb97dc7 SHA512 b69af1e8539f7d792e6c9ef002cbeeee95bd144148d55850a49e2759784b68ce07e19587365beb06cc138136498c0e952f7b16067567a5a2eaa31e9f4d47b8da
+EBUILD django-nose-1.4.4.ebuild 731 BLAKE2B 1030f2bfb2eb44de3f81e9403aee8b38050a596bf6652b7af21ea285f0759317c6f86e7f08f766e9bf80d276d027b68e09f64b78773ee93729c8f3b62e4043a1 SHA512 1215cf5d44d48448cc9832a7534eab9da575ca68c48e9d45caa7327348b2c105588624e0718c7ffe22976c0538a537b630e278fbcf9b898b7c9108fe7a4659c4
+MISC metadata.xml 385 BLAKE2B 776c504bb1b47f0bf19fa7e138b0ebdab5b8007e151e43d317d66f4cc9f3e5c273b710efd02edb57a923a37a1ce898a65b45d81232a4badb3b2da6ef7f77536b SHA512 39479b284469c8d29f60d39a8900ac5894c207706c4f141c565a52694b0fbf69b08ac77ca0dae44ec724e0548fee5a160a5d194033f06a53dea867787160a126
diff --git a/dev-python/django-nose/django-nose-1.4.4.ebuild b/dev-python/django-nose/django-nose-1.4.4.ebuild
new file mode 100644
index 000000000000..08ba94458ee6
--- /dev/null
+++ b/dev-python/django-nose/django-nose-1.4.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Django test runner that uses nose"
+HOMEPAGE="https://github.com/jbalogh/django-nose"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+#RESTRICT="test" # The testsuite currently broken See notes below
+
+RDEPEND="
+ >=dev-python/nose-1.2.1[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/dj-database-url-0.3.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ ./runtests.sh --verbose || die
+}
diff --git a/dev-python/django-nose/metadata.xml b/dev-python/django-nose/metadata.xml
new file mode 100644
index 000000000000..e712187829fd
--- /dev/null
+++ b/dev-python/django-nose/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-nose</remote-id>
+ <remote-id type="github">jbalogh/django-nose</remote-id>
+ </upstream>
+</pkgmetadata>