summaryrefslogtreecommitdiff
path: root/dev-python/django-openstack-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/django-openstack-auth
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/django-openstack-auth')
-rw-r--r--dev-python/django-openstack-auth/Manifest3
-rw-r--r--dev-python/django-openstack-auth/django-openstack-auth-3.2.0.ebuild75
-rw-r--r--dev-python/django-openstack-auth/metadata.xml18
3 files changed, 0 insertions, 96 deletions
diff --git a/dev-python/django-openstack-auth/Manifest b/dev-python/django-openstack-auth/Manifest
deleted file mode 100644
index 83d3fbb34321..000000000000
--- a/dev-python/django-openstack-auth/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST django_openstack_auth-3.2.0.tar.gz 69837 BLAKE2B 4ff5fdf15731668d91a5d0693f57c41ac3c373e45a1fcecc619d621bcbfda53a11e48a3de6afeae276d7320daf8e7eb9fc05e63f60f2b7c79d536b8f9c358f99 SHA512 43e8d19d73c934935f73b6dcb5a5ffbb0ca49c2c7dc892cadd9a04af94091e39bf35f1833d33474f7aeee9a94040424f6ee43c5fd355d8ad971c0b4ff971d4de
-EBUILD django-openstack-auth-3.2.0.ebuild 2128 BLAKE2B 15802dc0c99c1275b3b6e68a2e86f42d683bca254ccc0b0873805894a1cf5a7f35a23bdb3c3b84e143d081f09765ccbe6db6940309e259ea3d302f0f5098cf71 SHA512 80555209154b1021d161e8f82c61a5e042560181e137c35ab1928a935635a40a8f020a4e7c3c3ade23870dc3330e940799f2483b584cc4416f708b8a95dd5f87
-MISC metadata.xml 596 BLAKE2B f6aaee22ca4f6da9461dd4d83b100c319dde54d64c8bc951b5ea84dcd4749b5922b05ef828d570d7d953a095fe17bb24389892a177ad8181d24f5b21a6e4612f SHA512 84101c91533c60103627252f9392897cde375c39c26a66f72568b34feb1da4684f5ae63c6e83324b56bc5ea3efca97b4b22165bd0b93b5c9536e10916e695330
diff --git a/dev-python/django-openstack-auth/django-openstack-auth-3.2.0.ebuild b/dev-python/django-openstack-auth/django-openstack-auth-3.2.0.ebuild
deleted file mode 100644
index 7a83cbeb560e..000000000000
--- a/dev-python/django-openstack-auth/django-openstack-auth-3.2.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
-
-inherit distutils-r1
-
-MY_PN=${PN//-/_}
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Django authentication backend for use with OpenStack Keystone Identity backend"
-HOMEPAGE="https://django-openstack-auth.readthedocs.io/en/latest/"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-CDEPEND="
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-2.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hacking-0.12.0[${PYTHON_USEDEP}]
- <dev-python/hacking-0.14[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0[${PYTHON_USEDEP}]
- >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}] )
- ${CDEPEND}
- doc? ( ${CDEPEND} )
- "
-RDEPEND="
- >=dev-python/django-1.8[${PYTHON_USEDEP}]
- <dev-python/django-1.10[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-3.22.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-policy-1.17.0[${PYTHON_USEDEP}]
- >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
- >=dev-python/keystoneauth-2.20.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # Avoid warning in doc build due to missed file
- if use doc; then
- mkdir doc/source/_static || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # under sphinx-1.3.1 the build outputs a harmless warning about change of
- # html_theme setting in conf.py. priot versions will have the right setting
- if use doc; then
- sphinx-build -b html -c doc/source/ doc/source/ doc/source/html || die
- fi
-}
-
-python_test() {
- "${PYTHON}" -m openstack_auth.tests.run_tests || die "Testsuite failed"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/source/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/django-openstack-auth/metadata.xml b/dev-python/django-openstack-auth/metadata.xml
deleted file mode 100644
index a15856976eb6..000000000000
--- a/dev-python/django-openstack-auth/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>prometheanfire@gentoo.org</email>
- <name>Matthew Thode</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription lang="en">
- A Django authentication backend for use with the OpenStack Keystone Identity backend.
- </longdescription>
- <upstream>
- <remote-id type="pypi">django_openstack_auth</remote-id>
- </upstream>
-</pkgmetadata>