summaryrefslogtreecommitdiff
path: root/dev-python/django-openstack-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-python/django-openstack-auth
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-python/django-openstack-auth')
-rw-r--r--dev-python/django-openstack-auth/Manifest3
-rw-r--r--dev-python/django-openstack-auth/django-openstack-auth-3.2.0-r1.ebuild75
-rw-r--r--dev-python/django-openstack-auth/metadata.xml18
3 files changed, 0 insertions, 96 deletions
diff --git a/dev-python/django-openstack-auth/Manifest b/dev-python/django-openstack-auth/Manifest
deleted file mode 100644
index 080c58a380fe..000000000000
--- a/dev-python/django-openstack-auth/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST django_openstack_auth-3.2.0.tar.gz 69837 BLAKE2B 4ff5fdf15731668d91a5d0693f57c41ac3c373e45a1fcecc619d621bcbfda53a11e48a3de6afeae276d7320daf8e7eb9fc05e63f60f2b7c79d536b8f9c358f99 SHA512 43e8d19d73c934935f73b6dcb5a5ffbb0ca49c2c7dc892cadd9a04af94091e39bf35f1833d33474f7aeee9a94040424f6ee43c5fd355d8ad971c0b4ff971d4de
-EBUILD django-openstack-auth-3.2.0-r1.ebuild 2126 BLAKE2B dae0c770e2260e3c20647a1eeaad41c7ed7e861f6e493f718eb5f9c6b9ad07e5b5e1c993003a4c4233c0f59c5e601254e394b023ba87075263720641c823548f SHA512 4adfac22c36a5e6f2452335aa518d84c13d4fe460eebbfb5d31ceb60f75cc880693a62a79d7963f4bc9e36620087a8fc5a57a13ce1b6e4fbd400f263acd91fa1
-MISC metadata.xml 596 BLAKE2B f6aaee22ca4f6da9461dd4d83b100c319dde54d64c8bc951b5ea84dcd4749b5922b05ef828d570d7d953a095fe17bb24389892a177ad8181d24f5b21a6e4612f SHA512 84101c91533c60103627252f9392897cde375c39c26a66f72568b34feb1da4684f5ae63c6e83324b56bc5ea3efca97b4b22165bd0b93b5c9536e10916e695330
diff --git a/dev-python/django-openstack-auth/django-openstack-auth-3.2.0-r1.ebuild b/dev-python/django-openstack-auth/django-openstack-auth-3.2.0-r1.ebuild
deleted file mode 100644
index 5f7292f8f799..000000000000
--- a/dev-python/django-openstack-auth/django-openstack-auth-3.2.0-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5}} )
-
-inherit distutils-r1
-
-MY_PN=${PN//-/_}
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Django authentication backend for use with OpenStack Keystone Identity backend"
-HOMEPAGE="https://django-openstack-auth.readthedocs.io/en/latest/"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-CDEPEND="
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-2.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hacking-0.12.0[${PYTHON_USEDEP}]
- <dev-python/hacking-0.14[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0[${PYTHON_USEDEP}]
- >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}] )
- ${CDEPEND}
- doc? ( ${CDEPEND} )
- "
-RDEPEND="
- >=dev-python/django-1.8[${PYTHON_USEDEP}]
- <dev-python/django-1.10[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-3.22.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-policy-1.17.0[${PYTHON_USEDEP}]
- >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
- >=dev-python/keystoneauth-2.20.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # Avoid warning in doc build due to missed file
- if use doc; then
- mkdir doc/source/_static || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # under sphinx-1.3.1 the build outputs a harmless warning about change of
- # html_theme setting in conf.py. priot versions will have the right setting
- if use doc; then
- sphinx-build -b html -c doc/source/ doc/source/ doc/source/html || die
- fi
-}
-
-python_test() {
- "${PYTHON}" -m openstack_auth.tests.run_tests || die "Testsuite failed"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/source/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/django-openstack-auth/metadata.xml b/dev-python/django-openstack-auth/metadata.xml
deleted file mode 100644
index a15856976eb6..000000000000
--- a/dev-python/django-openstack-auth/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>prometheanfire@gentoo.org</email>
- <name>Matthew Thode</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription lang="en">
- A Django authentication backend for use with the OpenStack Keystone Identity backend.
- </longdescription>
- <upstream>
- <remote-id type="pypi">django_openstack_auth</remote-id>
- </upstream>
-</pkgmetadata>