summaryrefslogtreecommitdiff
path: root/dev-python/django-openstack-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/django-openstack-auth
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/django-openstack-auth')
-rw-r--r--dev-python/django-openstack-auth/Manifest5
-rw-r--r--dev-python/django-openstack-auth/django-openstack-auth-3.2.0.ebuild75
-rw-r--r--dev-python/django-openstack-auth/metadata.xml18
3 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/django-openstack-auth/Manifest b/dev-python/django-openstack-auth/Manifest
new file mode 100644
index 000000000000..ab9bf00d4c58
--- /dev/null
+++ b/dev-python/django-openstack-auth/Manifest
@@ -0,0 +1,5 @@
+DIST django_openstack_auth-3.2.0.tar.gz 69837 SHA256 e2a2970ddc73504afab477784c81f57c8c5c81daba55b0df30e1908acf5dd052 SHA512 43e8d19d73c934935f73b6dcb5a5ffbb0ca49c2c7dc892cadd9a04af94091e39bf35f1833d33474f7aeee9a94040424f6ee43c5fd355d8ad971c0b4ff971d4de WHIRLPOOL c7f3ca7a9ff016c8e8043d9a63f9092cb302b2db7b8c50d3d89b7384ace4a7e3a6dc9d594cc9f8e9993eafbdd91b01cd7e90a0a9caa3c987526f2c3b8a655802
+EBUILD django-openstack-auth-3.2.0.ebuild 2118 SHA256 996f28a31032d1942d92a66f4f9b368bbf4fceffc974564df151a509a7382f55 SHA512 330ee5fda7e82c1fef72696da8344582c89d2afebd28917a5eb795ab3fa099c314827dd136c65fd4b0da812461862a6f3afded42dd3d97af9d5e35e8417060a4 WHIRLPOOL 166c440070b540246fd2dcb5c84de6cd8e4bb2d51ee5e6ea404d00ea5923b7a9e55825ab9319a1c4fb969d966900879c67816c69d15210275e866d74e8db7065
+MISC ChangeLog 3524 SHA256 15cafed69c8b4b81e5d5e28c6ce6c405bc1cf2c7a592be83f86da98627445282 SHA512 ea8326689f04e2ef5801ef32bd6c107f8f16ce0f49c01011257fb8f30a0a74d10bfd379fb144061f2ec91b0474a327e160c904c4adf30aec819c5c70f2fe046b WHIRLPOOL 89b29166d9d3dd82097dc7f005302c4b16a8c57172b3826f6ed18de62c73c80e0bdd0666f9d02fb96f096e2e6805c613af727252704cc49cda598fc07925d311
+MISC ChangeLog-2015 1766 SHA256 43df3f0cc261c0ac46aae4419e2ac8b953ea065bc205dd083fbb3ddfb917a722 SHA512 64e93a04ae7315a72ca856b077d660fbb19bfe8b6b770cc20a57472f1a0804c98fb48bb2c6bc3f42793a6c658c6bdf6e2f8647b45d6cec19ad7781b4b2dbdb6b WHIRLPOOL ae1aa2058bcbd9f31e1d73b0097c37391cae1cb8d407afd56fdbbe177234afd55dab1384ceed7dea3ef269c234ce16c12185a047061116da4b53c5d4b6368b51
+MISC metadata.xml 596 SHA256 8947d3edf4b442594f164758a5c13ae5cbfe9908685feb89835ba215a5f37461 SHA512 84101c91533c60103627252f9392897cde375c39c26a66f72568b34feb1da4684f5ae63c6e83324b56bc5ea3efca97b4b22165bd0b93b5c9536e10916e695330 WHIRLPOOL 448e36b95a8d056dd8dee66d96f9d020a56c2bc17f99bce9153a1121c965cbfb9ec93c87b4a6e205d0729a8c3dda5a6acdbeee91a35152733eaf0460b2f39d41
diff --git a/dev-python/django-openstack-auth/django-openstack-auth-3.2.0.ebuild b/dev-python/django-openstack-auth/django-openstack-auth-3.2.0.ebuild
new file mode 100644
index 000000000000..9c8336ae2761
--- /dev/null
+++ b/dev-python/django-openstack-auth/django-openstack-auth-3.2.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+MY_PN=${PN//-/_}
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Django authentication backend for use with OpenStack Keystone Identity backend"
+HOMEPAGE="http://django_openstack_auth.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-2.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hacking-0.12.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.14[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}] )
+ ${CDEPEND}
+ doc? ( ${CDEPEND} )
+ "
+RDEPEND="
+ >=dev-python/django-1.8[${PYTHON_USEDEP}]
+ <dev-python/django-1.10[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-policy-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Avoid warning in doc build due to missed file
+ if use doc; then
+ mkdir doc/source/_static || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # under sphinx-1.3.1 the build outputs a harmless warning about change of
+ # html_theme setting in conf.py. priot versions will have the right setting
+ if use doc; then
+ sphinx-build -b html -c doc/source/ doc/source/ doc/source/html || die
+ fi
+}
+
+python_test() {
+ "${PYTHON}" -m openstack_auth.tests.run_tests || die "Testsuite failed"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/source/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/django-openstack-auth/metadata.xml b/dev-python/django-openstack-auth/metadata.xml
new file mode 100644
index 000000000000..a15856976eb6
--- /dev/null
+++ b/dev-python/django-openstack-auth/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ A Django authentication backend for use with the OpenStack Keystone Identity backend.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">django_openstack_auth</remote-id>
+ </upstream>
+</pkgmetadata>