summaryrefslogtreecommitdiff
path: root/dev-python/django-otp-yubikey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/django-otp-yubikey
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/django-otp-yubikey')
-rw-r--r--dev-python/django-otp-yubikey/Manifest3
-rw-r--r--dev-python/django-otp-yubikey/django-otp-yubikey-0.3.3.ebuild24
-rw-r--r--dev-python/django-otp-yubikey/metadata.xml9
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/django-otp-yubikey/Manifest b/dev-python/django-otp-yubikey/Manifest
new file mode 100644
index 000000000000..98405461ecc4
--- /dev/null
+++ b/dev-python/django-otp-yubikey/Manifest
@@ -0,0 +1,3 @@
+DIST django-otp-yubikey-0.3.3.tar.gz 14233 BLAKE2B a85eba8bf9c590d4747627baaaa6c038afea7d766203974508ee1ccb6bf807642720fae78a64584230f013daefd87475c5c9f94f1584ed4ddbdcfbdb31aee57d SHA512 80c9ffb42a7109a04eca4fabca33294b3a65abeb12f408cb6d7c6c06644896629df43d32833d514e0a60ddd6352af073fb5b2f1174a07b370214a76ccc093c3e
+EBUILD django-otp-yubikey-0.3.3.ebuild 572 BLAKE2B 2f9dfe15e30dd4cc43e27bd4c265e018db2f140499b07bb5edd48c4e1475972da4b922bd6feb1adff3e423ffa1eb3f39f23b7e6e5885ea2eec249d34a03cfbc6 SHA512 4a8800b24cabba93de68ccd8416bb8aa77ef29db4bb2ae00a6e1402f23c8d2883a1fcbf176e094a044ba1016c9f03c57bb3b5aed8f08c93d00eff15e0e459d6f
+MISC metadata.xml 316 BLAKE2B 07e00fa2de594708826250b71745951204e35e8ab7c74257eca61057a7bea5b2d9fb5f18724b0048da782f415751ceea4dbf4e79bcbb2135c77421a71a8937a8 SHA512 0a65b77aa7db9ea74f8643b05534fcaffaaedce5e7edbfc35c0f86e831c942b4464d9e4c225e3373d18b1b3a61e58976ffbd222843efcede3eacbb0d4177e597
diff --git a/dev-python/django-otp-yubikey/django-otp-yubikey-0.3.3.ebuild b/dev-python/django-otp-yubikey/django-otp-yubikey-0.3.3.ebuild
new file mode 100644
index 000000000000..ddf4f69cfa45
--- /dev/null
+++ b/dev-python/django-otp-yubikey/django-otp-yubikey-0.3.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="django-otp plugin that verifies YubiKey OTP tokens"
+HOMEPAGE="https://bitbucket.org/psagers/django-otp"
+SRC_URI="mirror://pypi/d/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/django-otp-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/yubiotp-0.2.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/django-otp-yubikey/metadata.xml b/dev-python/django-otp-yubikey/metadata.xml
new file mode 100644
index 000000000000..b600756496f9
--- /dev/null
+++ b/dev-python/django-otp-yubikey/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="pypi">django-otp-yubikey</remote-id>
+ <remote-id type="bitbucket">psagers/django-otp</remote-id>
+ </upstream>
+</pkgmetadata>