summaryrefslogtreecommitdiff
path: root/dev-python/django-otp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/django-otp
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/Manifest4
-rw-r--r--dev-python/django-otp/django-otp-1.1.2.ebuild35
-rw-r--r--dev-python/django-otp/django-otp-1.1.3.ebuild35
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index 9ee64de6d5ca..b7418b0f92e9 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1,3 +1,7 @@
DIST django-otp-1.1.1.gh.tar.gz 71526 BLAKE2B d68c0fe99c5437d08a8a0a433b4d6f41f0068047e3899efbb24234696c3494a064982aabc02d2788662d516235413bfc804f76cf5ffa1c608d3aa61927e2fad3 SHA512 5946cd64fd0f52dac5ef9fb192f8ecf78e99c96fe7e3223b41c68d96e249f6727149ef58a2dbf48024452e078f5f93c1f9edb9db2a25def5cbb3992c16aac18c
+DIST django-otp-1.1.2.gh.tar.gz 72639 BLAKE2B ba30e8d6c9982010dd9a627a810b9bc36474c571cbb6eb756d45b617338f18b7ceb024f88baeb7ceb6dbd76b3f5cf9ed53ebabd9dba435b6ab6cc3bdba092fa4 SHA512 85b34f9a36632ca44e4f7a3f11d1fd795bf65f909c0b6e4735afd56f06d754f7f28b43ccc851cb86c7330919978d3e2cb793111e50030273056da0231ee0e3ca
+DIST django-otp-1.1.3.gh.tar.gz 72736 BLAKE2B 1dc0570d65f0ac8de417260ce2fb895dbae7f5f2cd106b0dd969bc04df207cd4aa9ccf8be2bfc74475bb3ec6abcd451b7fa1c32fd0f7f0d3b27afca212f3b8ed SHA512 4e8b38c393fe29b2fa91e3f1f70abd2cc671dcf760e2e2bf8f738e04fc43a6e7f54229f298f7f2611988dffc40b4450ed1ab910ce9e9995b205dff1b3c90a977
EBUILD django-otp-1.1.1.ebuild 879 BLAKE2B edbde8fe955a2916043dc00c3d60eaf329439b71e56aa1c3a6c125c23b83cfefbd2134187214ef543b66d5fd42ee2f6be08fa9b9738e89326b28c2ea78de3eeb SHA512 be93ae1001eba37a7ddbc772466a42d44956bd5357eff20a90d616e5ddab1c1f63e9012a876023c85fb0dcb4164c88433146c73bdf6d1a18b1923df091b6a4ef
+EBUILD django-otp-1.1.2.ebuild 879 BLAKE2B edbde8fe955a2916043dc00c3d60eaf329439b71e56aa1c3a6c125c23b83cfefbd2134187214ef543b66d5fd42ee2f6be08fa9b9738e89326b28c2ea78de3eeb SHA512 be93ae1001eba37a7ddbc772466a42d44956bd5357eff20a90d616e5ddab1c1f63e9012a876023c85fb0dcb4164c88433146c73bdf6d1a18b1923df091b6a4ef
+EBUILD django-otp-1.1.3.ebuild 879 BLAKE2B edbde8fe955a2916043dc00c3d60eaf329439b71e56aa1c3a6c125c23b83cfefbd2134187214ef543b66d5fd42ee2f6be08fa9b9738e89326b28c2ea78de3eeb SHA512 be93ae1001eba37a7ddbc772466a42d44956bd5357eff20a90d616e5ddab1c1f63e9012a876023c85fb0dcb4164c88433146c73bdf6d1a18b1923df091b6a4ef
MISC metadata.xml 387 BLAKE2B f1be13d8af9a4926d7c82442cb939f1030a8234d4f18917cf8b2b8b204d763974b5f08f8597334238733d6446fc1165ba19d454e13105dc16afacf1fa3a98ea0 SHA512 d85060b9982c55057128a0c7b7fd1537e3eb613f9d44e6c40438283d76f6d65c92db78815005ce44b4096d57c62584659d5997491f003ca1ed8c36f88db8623c
diff --git a/dev-python/django-otp/django-otp-1.1.2.ebuild b/dev-python/django-otp/django-otp-1.1.2.ebuild
new file mode 100644
index 000000000000..892604810582
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="https://github.com/django-otp/django-otp/"
+SRC_URI="
+ https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/django-otp/django-otp-1.1.3.ebuild b/dev-python/django-otp/django-otp-1.1.3.ebuild
new file mode 100644
index 000000000000..892604810582
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.1.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="https://github.com/django-otp/django-otp/"
+SRC_URI="
+ https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
+}