summaryrefslogtreecommitdiff
path: root/dev-python/django-otp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/django-otp
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/Manifest4
-rw-r--r--dev-python/django-otp/django-otp-0.9.0.ebuild30
-rw-r--r--dev-python/django-otp/metadata.xml5
3 files changed, 37 insertions, 2 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index 2cd6f3558e09..b228363497cb 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1,3 +1,5 @@
DIST django-otp-0.4.3.tar.gz 42480 BLAKE2B 09398e4e06425fefdda45a3a200576efda9409a42fb8f1c640a996e066e1ad2cf47e6ee0879e4a61cdc64808fe8f030aba19dfd99fa4da7d3e86597bda881d09 SHA512 3f3ec761dc12ed40e8c757dfbe1fd951c7c6aed3abc311c823acdeca08d5864b54c8442a49807228be17b30c20093b1ba7fb8b2c0f86f00dc1cc215ccd7c28de
+DIST django-otp-0.9.0.gh.tar.gz 60204 BLAKE2B c71b27e007580410fea3cf8110631801c8c08f7e325c3586cb5a41a9618b371b5d65e3b030a5b483cb6cda684fe837cd40aa1c5d04f54dc82cda750b8ba8aeb9 SHA512 dd3c99e928ebf1ba5b6f6b2f34fcf8a1f86ad64ece17a9bd97c56be239f165808f6d1025e2826a12a8eadc150fe49920a0b7ef398d83542cd97a4a6f391505fe
EBUILD django-otp-0.4.3.ebuild 520 BLAKE2B 31eed615988aae630bca6a43529942ae683040ddfb89cc12eb5e9650afea430e7783bfdd47413dc7794ad4189cbe8664ab47b0f5c55df23636d631e06ff1c2df SHA512 1ecc8d9ea839367fd9e56e8d1e41cb9353d4e69a36ed75d8e40d34bd525fb3c7974e50a0840f0af6afe5cb6cdbcda6f4ad5f6d533c996d5bd94f1a518fa3726c
-MISC metadata.xml 308 BLAKE2B 4ab31e91721855334918e7c51072069b20202977309fe1e9509952351500a59b7daea3adafff99e44bb4ffdef76e900716e7718fefe3f4bb3f790a80955baf6c SHA512 06e2750aa7131626332ae0b473edb21ebba3ab26aeba63fde2dea4520c38a8e3d94e18e5f4aa5c759493059aa127858e1595975503f6a723611774d7fcd2550b
+EBUILD django-otp-0.9.0.ebuild 765 BLAKE2B ece769006ba4a4f8ead9ee89cd15224526bf8f21ece4155b84f05fea4dad1009da5225571c2b5171fbea013153c844ce8c22c36cfc738171739d2777d5d3ea6e SHA512 8b151507dc42dbc5d82be55ba8290bdede0703b49fc4d03109a4264362d04e9f3fddd9a60212fecb5906ebec9f75359e01038363db045389508e151b1b4861f5
+MISC metadata.xml 386 BLAKE2B f67c4bf653b25f3a4b8112f563255f4c28dfc76d7a5b91222b4908a524b13f60a3429d1b39ee7a6dc8d76f79785fb0a09eed4b918b252c2f931ae6bdc1ac6664 SHA512 16acfaae90557a8a259bb431f1004cba79c0c4274bee5efdd42aa4fbef74b5a7368832cbf6223b65acc2492820973d1c4e1c3e2f179d0a62985c7778659104ee
diff --git a/dev-python/django-otp/django-otp-0.9.0.ebuild b/dev-python/django-otp/django-otp-0.9.0.ebuild
new file mode 100644
index 000000000000..4bbf7d96389b
--- /dev/null
+++ b/dev-python/django-otp/django-otp-0.9.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="https://github.com/django-otp/django-otp/"
+SRC_URI="
+ https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/django-otp/metadata.xml b/dev-python/django-otp/metadata.xml
index 553985bc1948..60c8dcb8e859 100644
--- a/dev-python/django-otp/metadata.xml
+++ b/dev-python/django-otp/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<upstream>
<remote-id type="pypi">django-otp</remote-id>
<remote-id type="bitbucket">psagers/django-otp</remote-id>