summaryrefslogtreecommitdiff
path: root/dev-python/django-piston
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/django-piston
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/django-piston')
-rw-r--r--dev-python/django-piston/Manifest6
-rw-r--r--dev-python/django-piston/django-piston-0.2.3-r1.ebuild21
-rw-r--r--dev-python/django-piston/django-piston-9999.ebuild23
-rw-r--r--dev-python/django-piston/metadata.xml16
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/django-piston/Manifest b/dev-python/django-piston/Manifest
new file mode 100644
index 000000000000..14c6db09ba3f
--- /dev/null
+++ b/dev-python/django-piston/Manifest
@@ -0,0 +1,6 @@
+DIST django-piston-0.2.3.tar.gz 34319 SHA256 fb015137ceb7934f4645f7eb91a05d7bd63ef6bb1bd84f557ce55fac38e38ae9 SHA512 205cb15b4e59e7cb4d744525e149480ce9f54afa6b514c038ecf20df9221b4193d5041963b7217f40454c34d77125a1e52f0e7bfed5a471b27b1694a3af2ef6a WHIRLPOOL 364c8273a7542c43e18059b9c0ea6a110577ae190d2faa8cb268045556cf9d1882771ae05d907c907467562994be1367435c498329515d554eb675618f3bc50f
+EBUILD django-piston-0.2.3-r1.ebuild 502 SHA256 86ed0477ef1c2ed22be256b9e84523f2ef8bcad3c74662707f6837796c7ef8c2 SHA512 63e745aaf7ce5e1df9c4a8cb81b9a2b0994399a2a8524eac8a42be3d8b6ccec5b68a3fc4c38d3e32f24b4d9da92194325ce2a386227524ee844fe0f4fb2c383c WHIRLPOOL abec9fd6cc7ebdd22e13648fdff3c0b00e5cfe0bfe494c5654b8232b4d379ab32a2d730e4ed980099c67b46ce82db8b32c1e1a78f22258dee88f0ec4a8f84e1b
+EBUILD django-piston-9999.ebuild 534 SHA256 29b24b4a9faf019241921586cf95b5ff842199c6dcfc9969ddeaa07473efa56c SHA512 ceb34dea8d18d53ef80b1bc7140e951290fe9d984d2f2685d14f3e3a7d6165bf54d0f2ebe23dc04e6a2f2ee4e2823fba549a0879d96fa7e2f51a6ec365872854 WHIRLPOOL 9a01feb67e1396003df41aae49bb74567fdcd97fcdf2bcf1c7da60988c113d4de905da3cf515d69f715ca0d2752f79cc3619304a36574dc164f7e32a5e49d8e3
+MISC ChangeLog 2696 SHA256 91b1b647c7c344b55321a637f695b797a48c7b5074f3da6e168b3fa693f13252 SHA512 26de6d0b56fea5f6770f52a8ddff887b5ecf7b5f44e277b694d47389ac3685c9e40c06b67832fe3b03a881786638c0102b786fa3b428b175e31871718a184290 WHIRLPOOL 5aed877ceff6c056174fcdef43332eefac8d3e461c4ce4b636501da188d46d996d823b13c50e94050c74568c11d7c57d8c9427038752bb4db506a4e08e1c6573
+MISC ChangeLog-2015 1990 SHA256 7b6309dcb73c89e37909c95af315026c3e6dcebd10188005d87c0eb64bb253ff SHA512 6f863cb04fdacebe743401a54686bc5089684d907447e6783c01e05e75026cc006c06ecef35fc785a484d008332059ae90af99708f5b359a29f7e901a0e14d3d WHIRLPOOL 6f1555ba54dd384d55318f9106ec4ad371b83713584f3fbe52e44b96778a9b4c78f568c232cc0bc3cea7a8053cd589b9c7c1659967083819fc7779c4d0cc4129
+MISC metadata.xml 509 SHA256 c9460c311b08083132e2743e37c5923bd2450aef24ef222fa6728dce89c1a2eb SHA512 85971f86267acc6b22bbfa53fe1bc026644bb1fa190a67fc4fdb96990e2288fdff43bdec9a4a337ad5dbdfc0899802491f7e8acf99a6395d2ae9d9a17a14217b WHIRLPOOL 75b95f48e05840c9df5c0d801ab91cc67e3378377f90f40e06cc316ffbdb505af8fc27dc181f9c87d78a9d71f27c227c38d076bd330bfc9fd43cdb85a3153c66
diff --git a/dev-python/django-piston/django-piston-0.2.3-r1.ebuild b/dev-python/django-piston/django-piston-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..740a98826961
--- /dev/null
+++ b/dev-python/django-piston/django-piston-0.2.3-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A mini-framework for Django for creating RESTful APIs"
+HOMEPAGE="https://bitbucket.org/jespern/django-piston/wiki/Home"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/django-piston/django-piston-9999.ebuild b/dev-python/django-piston/django-piston-9999.ebuild
new file mode 100644
index 000000000000..dfbb04644206
--- /dev/null
+++ b/dev-python/django-piston/django-piston-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 mercurial
+
+DESCRIPTION="A mini-framework for Django for creating RESTful APIs"
+HOMEPAGE="https://bitbucket.org/jespern/django-piston/wiki/Home"
+EHG_REPO_URI="https://bitbucket.org/jespern/django-piston/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}"
diff --git a/dev-python/django-piston/metadata.xml b/dev-python/django-piston/metadata.xml
new file mode 100644
index 000000000000..3c7fd0b88127
--- /dev/null
+++ b/dev-python/django-piston/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-piston</remote-id>
+ <remote-id type="bitbucket">jespern/django-piston</remote-id>
+ </upstream>
+</pkgmetadata>