summaryrefslogtreecommitdiff
path: root/dev-python/django-piston
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/django-piston
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/django-piston')
-rw-r--r--dev-python/django-piston/Manifest4
-rw-r--r--dev-python/django-piston/django-piston-0.2.3-r1.ebuild21
-rw-r--r--dev-python/django-piston/django-piston-9999.ebuild23
-rw-r--r--dev-python/django-piston/metadata.xml16
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/django-piston/Manifest b/dev-python/django-piston/Manifest
new file mode 100644
index 000000000000..c0198f2d415b
--- /dev/null
+++ b/dev-python/django-piston/Manifest
@@ -0,0 +1,4 @@
+DIST django-piston-0.2.3.tar.gz 34319 BLAKE2B 36d0f724fee72c0dece8b91b55a8aac5140db8f319b16221c0982caec72bfcae734b74165bd267073b2be59e1907f6936e640c4c60e5768934cfaae91f02b1f8 SHA512 205cb15b4e59e7cb4d744525e149480ce9f54afa6b514c038ecf20df9221b4193d5041963b7217f40454c34d77125a1e52f0e7bfed5a471b27b1694a3af2ef6a
+EBUILD django-piston-0.2.3-r1.ebuild 502 BLAKE2B 57fb9441aab123122a6961e38865616671ba71a63d8754062a7be64ccdd1e39089e8f81e4208a8483ef77b47de6410770f590eb2114b15839f91ea0714411db4 SHA512 63e745aaf7ce5e1df9c4a8cb81b9a2b0994399a2a8524eac8a42be3d8b6ccec5b68a3fc4c38d3e32f24b4d9da92194325ce2a386227524ee844fe0f4fb2c383c
+EBUILD django-piston-9999.ebuild 534 BLAKE2B d672e1cafd5e75a4360e84dcbe8f4ba4809d8714947c3ca2d6d4bbcee9c0e3c5da33f0111502480c616bd05aa44ccd15a60f74c2f02d62b03ae453295203f6d2 SHA512 ceb34dea8d18d53ef80b1bc7140e951290fe9d984d2f2685d14f3e3a7d6165bf54d0f2ebe23dc04e6a2f2ee4e2823fba549a0879d96fa7e2f51a6ec365872854
+MISC metadata.xml 509 BLAKE2B d2ca0f89d6e7e642bd7855a67f5b8c736f3b33471cb01ded38468bebf44184061a7c845e1d5267ee94c2558159d06ddccfcca55cb7a9c589779914477b031030 SHA512 85971f86267acc6b22bbfa53fe1bc026644bb1fa190a67fc4fdb96990e2288fdff43bdec9a4a337ad5dbdfc0899802491f7e8acf99a6395d2ae9d9a17a14217b
diff --git a/dev-python/django-piston/django-piston-0.2.3-r1.ebuild b/dev-python/django-piston/django-piston-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..740a98826961
--- /dev/null
+++ b/dev-python/django-piston/django-piston-0.2.3-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A mini-framework for Django for creating RESTful APIs"
+HOMEPAGE="https://bitbucket.org/jespern/django-piston/wiki/Home"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/django-piston/django-piston-9999.ebuild b/dev-python/django-piston/django-piston-9999.ebuild
new file mode 100644
index 000000000000..dfbb04644206
--- /dev/null
+++ b/dev-python/django-piston/django-piston-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 mercurial
+
+DESCRIPTION="A mini-framework for Django for creating RESTful APIs"
+HOMEPAGE="https://bitbucket.org/jespern/django-piston/wiki/Home"
+EHG_REPO_URI="https://bitbucket.org/jespern/django-piston/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}"
diff --git a/dev-python/django-piston/metadata.xml b/dev-python/django-piston/metadata.xml
new file mode 100644
index 000000000000..3c7fd0b88127
--- /dev/null
+++ b/dev-python/django-piston/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-piston</remote-id>
+ <remote-id type="bitbucket">jespern/django-piston</remote-id>
+ </upstream>
+</pkgmetadata>