summaryrefslogtreecommitdiff
path: root/dev-python/django-prometheus/django-prometheus-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/django-prometheus/django-prometheus-2.2.0.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/django-prometheus/django-prometheus-2.2.0.ebuild')
-rw-r--r--dev-python/django-prometheus/django-prometheus-2.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/django-prometheus/django-prometheus-2.2.0.ebuild b/dev-python/django-prometheus/django-prometheus-2.2.0.ebuild
new file mode 100644
index 000000000000..79c9b92ea2d7
--- /dev/null
+++ b/dev-python/django-prometheus/django-prometheus-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Library to export Django metrics for Prometheus"
+HOMEPAGE="https://github.com/korfuri/django-prometheus"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/prometheus_client-0.7[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i "/pytest-runner/d" setup.py || die
+ distutils-r1_python_prepare_all
+}