summaryrefslogtreecommitdiff
path: root/dev-python/django-recaptcha
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/django-recaptcha
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/django-recaptcha')
-rw-r--r--dev-python/django-recaptcha/Manifest3
-rw-r--r--dev-python/django-recaptcha/django-recaptcha-1.0.5.ebuild26
-rw-r--r--dev-python/django-recaptcha/metadata.xml12
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/django-recaptcha/Manifest b/dev-python/django-recaptcha/Manifest
new file mode 100644
index 000000000000..f5b35ae4eab6
--- /dev/null
+++ b/dev-python/django-recaptcha/Manifest
@@ -0,0 +1,3 @@
+DIST django-recaptcha-1.0.5.tar.gz 12827 BLAKE2B d17799e891c083adb005de488b4d8f3d7113c4440296d2b0ba5d7a29bc0177a85543dda84511a7a80e82781133bc13be6eda63ac22ba7e471ed7e1a41a662b99 SHA512 2ccf0a6c25d242d86ef7e89705d3f299c94c0ee2fc40853db9bb8cf1f7397650dcde85f1a6d995d452d432ce947bd8fa850d64334d4c124ddc9315cab6fe222c
+EBUILD django-recaptcha-1.0.5.ebuild 738 BLAKE2B ba03c56e39a7e8d54892060233570b2c967905a80fd7fdef8ec2ab3c7af3fa6aa62239894fa6a7225a1aa5a625b449bfb704c23b6c707ea562a369534ee6556b SHA512 15bbd4a671465c6b5193b8850cdf57b2b4f5ca81d79e8fe8461a9e36159c21458ae13ca9015b53065aaf9423e060bc68f3f9abffa1bf87447d9b766255ac8fd5
+MISC metadata.xml 384 BLAKE2B 0b35dcdb2b5e934a3ca8ec179c7ae62b6810dc53ea51a58f1fbc5f30c9487dc0a3afc68f4183c3688a950115a00a867c77044f6df7e7d97f1b4bf7c915abc343 SHA512 ada7280319fd9fafeb8c9096a472bf88d1d49508733e7d847f08e33cc084f73dbd304af6be1725610127bc1ed054dbe66b74c6a3faf5c20520d4ea8d4e2087c8
diff --git a/dev-python/django-recaptcha/django-recaptcha-1.0.5.ebuild b/dev-python/django-recaptcha/django-recaptcha-1.0.5.ebuild
new file mode 100644
index 000000000000..7354afbf9f5f
--- /dev/null
+++ b/dev-python/django-recaptcha/django-recaptcha-1.0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Django recaptcha form field/widget app"
+HOMEPAGE="https://github.com/praekelt/django-recaptcha https://pypi.org/project/django-recaptcha/"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/praekelt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/django-setuptest-0.2.1[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/django-recaptcha/metadata.xml b/dev-python/django-recaptcha/metadata.xml
new file mode 100644
index 000000000000..4e397cbfaf98
--- /dev/null
+++ b/dev-python/django-recaptcha/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-recaptcha</remote-id>
+ <remote-id type="github">preakelt/django-recaptcha</remote-id>
+ </upstream>
+</pkgmetadata>