summaryrefslogtreecommitdiff
path: root/dev-python/django-registration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-09 03:03:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-09 03:03:12 +0000
commit2be329ae14bbf99f0fc4de7567e2386bbb529fdc (patch)
tree99e1d21f40429392d5eb255ec008fdd96e4fa284 /dev-python/django-registration
parent2cd9ff612e84f0c1ef63c9e9e13be53fe576cc2b (diff)
gentoo auto-resync : 09:11:2024 - 03:03:12
Diffstat (limited to 'dev-python/django-registration')
-rw-r--r--dev-python/django-registration/Manifest2
-rw-r--r--dev-python/django-registration/django-registration-5.1.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/django-registration/Manifest b/dev-python/django-registration/Manifest
index 0346d30bb1be..b8fd8a7ed8ad 100644
--- a/dev-python/django-registration/Manifest
+++ b/dev-python/django-registration/Manifest
@@ -1,3 +1,5 @@
DIST django-registration-3.4.gh.tar.gz 81582 BLAKE2B bc3ee4ed806486c8a0422cc4ef62c2628f6b5880e0aa63ffdfd5ba7f90967c96c5cd7555faf58254e0a49bdb025b9bdf8eb212bfce4596db7db4f97e4eb3400d SHA512 b6c87cbaeb9548e2c2d8672078b5967aee1e881c2b880193ba410a8c293c93fd0c8e57abac8deda2cb6f61a11936fd5c72060e4954f1d74de1e3a3646b63885b
+DIST django-registration-5.1.0.gh.tar.gz 92245 BLAKE2B ccd1c0c34a0a579877b36eb25639887d148132ce552ef3fa9df5f36a0f05a5f7d290f6f1a5b2e8584dec53b6646cdf776a0a2154792f06432d38813badf98975 SHA512 81feb228c27ed433a97546e4ace794f8718d6c3a5d741507d36cb142a63aa20f31259604945dde0020656d8240e0e4cf46295b0e9082e2e1a9cb4fb025472ff8
EBUILD django-registration-3.4-r1.ebuild 759 BLAKE2B 72a686fe2e5ee7abdf679d808c954a9c63ba98c32301fd8ca757f3a501fcf744da9989aa1bb77789d95d58fff427d8a35af71794cd9e772329f4937b2a2402b5 SHA512 77a641e742dc30b81322531b6f0330e06e679cd6c9defc52b9e3db7e0e4ff25650b6052a3b7f6cee1ae3a641223b10409d6cb02009cafa2d43dbe14caa461413
+EBUILD django-registration-5.1.0.ebuild 773 BLAKE2B 70be1f539c39900a1ef3a6091df46e41c2df293e27964cb143502a3564ddb54c5de1084136e51b920f6141c1cfc0fa98d52e025dece813879603188d38b9443d SHA512 5357597c26a0b64d92facdad4a0b88b904058d2090056cfdc0b85592dcb80a46a852dd48b0ac450a9e0fcd2f981f1a6c0a2e48fbcab556dbccc15adf7dc0441a
MISC metadata.xml 401 BLAKE2B 695741a0b4b269cf5f259a00fbfa4527872aa396495468b9996a78be679238fdf67986185cb00dd616d048a6ce5d4aa9525b99dbe1af4c980d5caa9bc6936368 SHA512 79fe2b9fe95515d02be6b910273228c9b9b63e598ed1868be6e3c7895562db1362b9304bf9858c76fb3e6c7efc8bada88f2a74c756b72a024ff171fd425ca761
diff --git a/dev-python/django-registration/django-registration-5.1.0.ebuild b/dev-python/django-registration/django-registration-5.1.0.ebuild
new file mode 100644
index 000000000000..3596be0ba0de
--- /dev/null
+++ b/dev-python/django-registration/django-registration-5.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="user-registration application for Django"
+HOMEPAGE="
+ https://pypi.org/project/django-registration/
+ https://github.com/ubernostrum/django-registration/
+"
+SRC_URI="
+ https://github.com/ubernostrum/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/confusable-homoglyphs-3.0[${PYTHON_USEDEP}]
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings
+ PYTHONPATH=. "${EPYTHON}" runtests.py || die "Tests failed with ${EPYTHON}"
+}