summaryrefslogtreecommitdiff
path: root/dev-python/django-registration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-22 14:50:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-22 14:50:54 +0100
commit5772eab78c27d5409ea9e818a12abc9f686e7319 (patch)
tree781df06984c0a557c2fade1ffa96a39378bfbf7c /dev-python/django-registration
parent45219c7455b2c8bce47bdf428b44a6a38d6ce521 (diff)
gentoo auto-resync : 22:07:2023 - 14:50:54
Diffstat (limited to 'dev-python/django-registration')
-rw-r--r--dev-python/django-registration/Manifest2
-rw-r--r--dev-python/django-registration/django-registration-3.3-r1.ebuild (renamed from dev-python/django-registration/django-registration-3.3.ebuild)11
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/django-registration/Manifest b/dev-python/django-registration/Manifest
index 44f76ab99e8d..a975d50a3aba 100644
--- a/dev-python/django-registration/Manifest
+++ b/dev-python/django-registration/Manifest
@@ -1,3 +1,3 @@
DIST django-registration-3.3.gh.tar.gz 77483 BLAKE2B 4d65479983a5aa104daffe07ed84218250893ccf6df44e5533473d587a6e76fe71c905124af3909efda515ea84df49f27eafc32f23480ca3e1f6ef55607b3cd7 SHA512 66ef0de4c1adb303717cf87e9d3ce7ab07ca60bab64cbc810f61f31d05a968c0b4fa216b90e7ad575e647c6fdb789ea875c428b0ca8b0104d055ed0882aae144
-EBUILD django-registration-3.3.ebuild 630 BLAKE2B 5e1bbff742b62c27b6ea4dae4fc2b8d46567766caec6d2c48c59c54d5f08741456c3a5183742f8527f57a9fd661a05396027968001b7947bc7afc2a2863ccac2 SHA512 645ae2994ed57d0084597d7b29a1e5c2d72e8d2d4003027294e775a285004f84f9e46dd4385397a54bc1da97a24d71a0a396f7ff4dd01d925f04ac79c13c2509
+EBUILD django-registration-3.3-r1.ebuild 696 BLAKE2B e4fbc1757697f26f0786e1c01f79b1df654f2aa288f37fa5658c7cfd93d986aaac228f162d0a3812182e9f622b2f95f0bc75c57e5c9fd689f49376a2e3121c01 SHA512 182cea2eebde5eb18b8158d562a1bd3e33cab17366f8e12eefb32b7b53034667b9d425eb2fff28edb6baf8f86fdec402565f52b44c3f9d94b95607b74d7835ef
MISC metadata.xml 401 BLAKE2B 695741a0b4b269cf5f259a00fbfa4527872aa396495468b9996a78be679238fdf67986185cb00dd616d048a6ce5d4aa9525b99dbe1af4c980d5caa9bc6936368 SHA512 79fe2b9fe95515d02be6b910273228c9b9b63e598ed1868be6e3c7895562db1362b9304bf9858c76fb3e6c7efc8bada88f2a74c756b72a024ff171fd425ca761
diff --git a/dev-python/django-registration/django-registration-3.3.ebuild b/dev-python/django-registration/django-registration-3.3-r1.ebuild
index 385e2ce8ccb0..ae512f2de161 100644
--- a/dev-python/django-registration/django-registration-3.3.ebuild
+++ b/dev-python/django-registration/django-registration-3.3-r1.ebuild
@@ -20,8 +20,13 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-RESTRICT="test" # Tests are not working here
-RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/confusable_homoglyphs[${PYTHON_USEDEP}]
+"
-distutils_enable_tests pytest
+python_test() {
+ "${EPYTHON}" runtests.py \
+ || die "Tests failed with ${EPYTHON}"
+}