summaryrefslogtreecommitdiff
path: root/dev-python/django-tables2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-25 06:31:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-25 06:31:02 +0000
commite80134587e8d959a88dba7dd3784895372e205c8 (patch)
tree912d9772fcc93ec668b363146cf81e45519253d6 /dev-python/django-tables2
parent17e417b73cb3e25edbc6541bd107bc9c593d66bd (diff)
gentoo auto-resync : 25:12:2024 - 06:31:02
Diffstat (limited to 'dev-python/django-tables2')
-rw-r--r--dev-python/django-tables2/Manifest2
-rw-r--r--dev-python/django-tables2/django-tables2-2.7.4.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/django-tables2/Manifest b/dev-python/django-tables2/Manifest
index 810af443521c..dc6a2d8bdac2 100644
--- a/dev-python/django-tables2/Manifest
+++ b/dev-python/django-tables2/Manifest
@@ -1,5 +1,7 @@
DIST django-tables2-2.7.0.gh.tar.gz 431811 BLAKE2B 2a6a9d74fa50bab049b9b85fc4a2d39b5a54b0fbbcd51f86f2b196e51bd1a1ef36ccc032db13f7cde4f836419a2d92248571b4fb985a8aefb3be2bb740856a2b SHA512 9666dad152d995ef7772881ace4bb83fc41aca1675e0cc116791e4fbfb970de600bd8cc2310b5694558b11e479dea2fc84584a669f6a8127a4bb0a354d24e39a
DIST django-tables2-2.7.1.gh.tar.gz 432168 BLAKE2B b23940aaa6c0bade140d9342179ed776e413ac081ae25f4f0a73a9ac2613f7e8bef8e672fc9fcaedbff56268aca0616a19304d0ce79f93961be67e465ea548eb SHA512 74d74f987c8b8347e505c3672e08b37ec5b5a1865a7ff6f394ff4ab5a2f2410356207466994bbe03e20f5c4340f0b212e7b40f95038f47df36760f7256e126ca
+DIST django-tables2-2.7.4.gh.tar.gz 432112 BLAKE2B 9327506570115f8bfdce95a753327d3ce94d6b9b03c250ee141c368fb872c0778f6b194aae9518abcdf8c3e53ea522ee7690ab86460694a86624d1d2572b0f98 SHA512 19437869dabf5376eb243aa6529c3e70b4448248c021d3bf8e64865bcdac0d21c5fbc91e5fb0891ee449c04c735f84a68916e15ce3149f3a4d7c05b4866ba705
EBUILD django-tables2-2.7.0.ebuild 1106 BLAKE2B 3e30f676c073ea85a5bdc0fc88e8b45c68c78138af0090c18933254ec1b86f7f4265cb770aa275a870d2ca3c946290c3a8bfe585784731302a4d8c9d352a7b44 SHA512 35c9db146a58ce3be26c629889ea41a875514f04d902ed6754f39b14a38826c50bbfd072608c48e2af7e9bb39d5db1c8c3f9afe5326d96aee37d6703bec74bb4
EBUILD django-tables2-2.7.1.ebuild 995 BLAKE2B 14422ae0261c77989c0234f2d4a7dfab8e68c2611a1bb96575eeb4f06064a8f46d055163a72eeffa9f137a43a8112a297805f7d8dd3313e2975a099323012511 SHA512 a1ec26bbf2414caa77a6b6829c6c9cf046b7dc2292935fe77fe629ee9900eca4503d38ff0a9fe105e78b595d1a1aefff40df05bf9d0cf2fc3ec4896dfdbdaa40
+EBUILD django-tables2-2.7.4.ebuild 994 BLAKE2B 88e15c9d292bff26f261d00f42e5b0134a144c2b0bc820e5f27e7477055cee2c2051b5acc1c9b9cbdfcc52e069d236c3b5d57fe52f035c2c1cbb0204508ec245 SHA512 306d824858aefcf0b906bba5664f36f483e758de3d7efd57b653000bcb98d42763182712df187178523e7861add8bb7bbf3b51da0e9b7fe4ebb2f9b81ea9417c
MISC metadata.xml 416 BLAKE2B f63a86611d3d5805c63f14c75851d6283f12777fce462a796c205ca4141fd5d5a321a7173f2b8bda70d67a3db5935864ca632e6858757626ed632fe3ec6874fb SHA512 1cf202a6a5fcbe86157ba8bf71f5c0c8df2c4393dcc955b2ad37e4f2164a33e241287bed237116df298e6a062a861ec99f3326d13f8f5845891556eb36d9bbf3
diff --git a/dev-python/django-tables2/django-tables2-2.7.4.ebuild b/dev-python/django-tables2/django-tables2-2.7.4.ebuild
new file mode 100644
index 000000000000..6820b423e7ec
--- /dev/null
+++ b/dev-python/django-tables2/django-tables2-2.7.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Table/data-grid framework for Django"
+HOMEPAGE="
+ https://pypi.org/project/django-tables2/
+ https://github.com/jieter/django-tables2/
+"
+SRC_URI="
+ https://github.com/jieter/django-tables2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/django-filter[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/psycopg:*[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # these tests require tablib
+ rm tests/test_export.py tests/test_templatetags.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" manage.py test -v 2 tests || die
+}