summaryrefslogtreecommitdiff
path: root/dev-python/django-taggit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-30 01:25:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-30 01:25:53 +0100
commitf16e0a3eea2c1d2e5c495ed1802dea365b4fda4b (patch)
tree8942fce466ff12eb53fafa1a5731ff2751fcd593 /dev-python/django-taggit
parent04ac238703da84168e02b06fb131d1d17d85be23 (diff)
gentoo auto-resync : 30:09:2024 - 01:25:52
Diffstat (limited to 'dev-python/django-taggit')
-rw-r--r--dev-python/django-taggit/Manifest2
-rw-r--r--dev-python/django-taggit/django-taggit-6.1.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/django-taggit/Manifest b/dev-python/django-taggit/Manifest
index 31fee0ae8d8a..68b9592f2b22 100644
--- a/dev-python/django-taggit/Manifest
+++ b/dev-python/django-taggit/Manifest
@@ -1,3 +1,5 @@
DIST django-taggit-5.0.1.tar.gz 60372 BLAKE2B 1934fc0a92655db15a4997646c44d8faa57b48469421abb7c48ea248525f0c536d658a9a481ed646dc4846c2f8f6ca9799274f9961238bd727ef0bafbb0ddf0c SHA512 af7b04da8359ebf68ea1b5c1fba3ed509b5357d65cccd95d835e0db68431fcbf0057e613cd05c54ac76524c8fc1c23d0dbacae8b80a23bb7867a0fa4a62f445b
+DIST django-taggit-6.1.0.gh.tar.gz 146478 BLAKE2B 3480f0a2c3b6e5ee48789bf00331da623d54218ef36e80e60797287fdb9953ae382e90d1bcdcbe8ff9af440530a12b573a17b0218e6f81a5f40c6d26a61b81a7 SHA512 60060e9674f7cca24704d786c5dd7bf985ce4891ed0c2bfed532f1033b97e2fca45b52eeacd475eda17062bb5e11605ebdef745cc45e1ca77a8e654aad1f80e1
EBUILD django-taggit-5.0.1.ebuild 716 BLAKE2B 06064b98c334fcf6158a0f5ee1611a71fbb3068a5cb155651f11ddde0c832f427fdeb023257a495d7bd365b13877aa968d2ee350b2957d6f2dac9f90b3369666 SHA512 31405e5c2b2599d3aec355809930ffac2ce723ca37618c11266fb53fa746eb5c536afcdb82ee97bca145ad76debc7ad29fafd4628070e866d2d79c44ed257aba
+EBUILD django-taggit-6.1.0.ebuild 1053 BLAKE2B acb068ffb5991c60f0c3c826f22dc08abde777dfe7daa8679cd9e73c059e9cd554359367ce42897cbb0a5d4a7333697ed9e769e128d03bb7e408a373145090a9 SHA512 59d10cb504ce5aa11107d1a0308ca4ce1d231d23f2f443a854c1e9cdac23621da01fb12a0ed7f0e580977103406e4852463f33601b304d1c1629fc92043b1386
MISC metadata.xml 403 BLAKE2B efc93b9f0dc7eba3753e8c205a903f6873d1683b7e7c7a9558c1e561a9f4625bb7aaeb79e381c98ab160fe90b53d72f219981453ae3a4a48a53bcf17f079a1bd SHA512 aaab76dac654f034873a24bc13e0d448d67b865a9dceb706ea13bf9544b423b07e3246e7936f072b9664e7e62a6b6506df482a2197a3e165520a2cb77c766b9b
diff --git a/dev-python/django-taggit/django-taggit-6.1.0.ebuild b/dev-python/django-taggit/django-taggit-6.1.0.ebuild
new file mode 100644
index 000000000000..305c35d375af
--- /dev/null
+++ b/dev-python/django-taggit/django-taggit-6.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple tagging for Django"
+HOMEPAGE="
+ https://github.com/jazzband/django-taggit/
+ https://pypi.org/project/django-taggit/
+"
+SRC_URI="
+ https://github.com/jazzband/django-taggit/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/django-4.1[${PYTHON_USEDEP}]
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ if has_version "dev-python/unidecode[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ # https://github.com/jazzband/django-taggit/issues/856
+ tests/test_models.py::TestSlugification::test_old_slugs
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p django -o DJANGO_SETTINGS_MODULE=tests.settings
+}