summaryrefslogtreecommitdiff
path: root/dev-python/django-timezone-field
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-python/django-timezone-field
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-python/django-timezone-field')
-rw-r--r--dev-python/django-timezone-field/Manifest2
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-4.2.3.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/django-timezone-field/Manifest b/dev-python/django-timezone-field/Manifest
index 9d6da9f8fcfc..f5d0837383f5 100644
--- a/dev-python/django-timezone-field/Manifest
+++ b/dev-python/django-timezone-field/Manifest
@@ -1,3 +1,5 @@
DIST django-timezone-field-4.2.1.gh.tar.gz 23457 BLAKE2B 72452a21e6e086363da2ef40389d12b79860f66706e54fb9050ffe48f7fa6ad2908c75d4c7e17a79df339eac76492599dd4533ddca69a5b8757b46a36ed4b0fc SHA512 4c2da420c3aaffa23d8cdb66dbbe4b2ea8638de5a45d9e381bf9af980e52eba77fc03a2b8fee8497662199cdc9436d56543c0f6316e74ae5da68187a305c34a2
+DIST django-timezone-field-4.2.3.gh.tar.gz 23605 BLAKE2B d183fb57254a6a1c86ca57558b88d5429d1d4d368c2cbf2f7a7f4d5414432fd80c5ae1df30793da185d5347afe8535dd821e7e605fb0693f26619b319894a6a3 SHA512 1a72ee557b5b527d2aeae9033c765272ebdd017d9e05708734e9bcdf6355e2747e1ce920a542dbead2d8fc6043024ece24adb3b27ccd6d0f2c8e5b3eb907e012
EBUILD django-timezone-field-4.2.1.ebuild 807 BLAKE2B 6b9fe27cf74bf9a38679c8c78cfc92bc8d3b60839a6118546b003d2d33b120010f084fdd785f4fdf0f9932de53e6cdf077476f0fb092461afbb2a5e79ede1d0e SHA512 1f175570d95e3a7fcc0fe3cd0a30f3908bd2bced12c0bda740a5e90347887cd7689ac60bd984c07964822d0ff242d8845b8a567cca2941cc375ce3ef802c4b7c
+EBUILD django-timezone-field-4.2.3.ebuild 807 BLAKE2B 318c8fd30d009fe3301b0f3e4432077b30ac6dd16331210dc27de262a0bc5a8be1d0913c7b8fa695ac57d67d84a321541af1e2d3fb8cce58b8522d8dd8f313eb SHA512 7e28684261aad0378f757b1c9914bf91aed40ec3a6705886474c7e0f4ca1d48906365f9b39d8c80a4508e7c916126516864f34299f3169d6a997eb869e2e3b67
MISC metadata.xml 325 BLAKE2B 481e3472db098df8d49a956b8771b6f32a7bfff8d0ab5a5d556a76c1dfbf4d393e566aed3bec7b8da37b72641f01ef34f1eeb4f5862bd7930facf517dff95875 SHA512 878eac6d1101f54284c6a33bc6458e6a9fa272dd3bc3c824f45e3c0b7b51835de2c9b80c312860e5d1dea0ca6fa1ad44b5e32d61cade7b818ffb4aa9427fed20
diff --git a/dev-python/django-timezone-field/django-timezone-field-4.2.3.ebuild b/dev-python/django-timezone-field/django-timezone-field-4.2.3.ebuild
new file mode 100644
index 000000000000..1f18eee3c76a
--- /dev/null
+++ b/dev-python/django-timezone-field/django-timezone-field-4.2.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Django app providing database and form fields for pytz timezone objects"
+HOMEPAGE="https://github.com/mfogel/django-timezone-field"
+SRC_URI="
+ https://github.com/mfogel/django-timezone-field/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DB_ENGINE=sqlite
+ epytest
+}