summaryrefslogtreecommitdiff
path: root/dev-python/djangocms-picture
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/djangocms-picture
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/djangocms-picture')
-rw-r--r--dev-python/djangocms-picture/Manifest4
-rw-r--r--dev-python/djangocms-picture/djangocms-picture-2.0.5.ebuild32
-rw-r--r--dev-python/djangocms-picture/metadata.xml10
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/djangocms-picture/Manifest b/dev-python/djangocms-picture/Manifest
new file mode 100644
index 000000000000..00d1b9ed19e5
--- /dev/null
+++ b/dev-python/djangocms-picture/Manifest
@@ -0,0 +1,4 @@
+DIST djangocms-picture-2.0.5.tar.gz 32329 SHA256 8d890452dd2fdfbcc3d1601411deea6664b01ec870c2791d39d2b1d27db740c7 SHA512 df4ba02d06966d7cee38254baadea5eeb5197557cbda1e8a202e45420881b6216efcc49fa8a6e9f9af30507a93ee2f7110e14e5ae3a645b889c990dfaca3a499 WHIRLPOOL 228022352e3ec8486fcb2cce07130169586f5f92cdc2f7c2221f2fa5d798c72d85ea96a1ce728802b29643409091016e24a1851dcadd728672b0bf17c7b4be9e
+EBUILD djangocms-picture-2.0.5.ebuild 754 SHA256 2d35692f1e19193709e5d6865457ff00058bbc814b3a1a2f117bcfab854f84dc SHA512 3f0ff6cd0faad45bf069e194a7d4c70877ef1edda2077975351ff2e756ce12dbae77c94be26030a51e8be6b7094298ea7ea0a93f35e6be166b92f2baaec3309d WHIRLPOOL f3a8834f638318c15fbc4d7e030f9b3ec99556579943de259721c3623143b6a0ec95fea5fc4f5dbd8b94ae6014a72b81e975cf9681828b85a121a82a5e26973f
+MISC ChangeLog 2118 SHA256 6eeced405efdedc985bb2937144e20d53d67b691183d3c9404042c3d76ad0f5d SHA512 17c47e65d34d23999b333d2e7a2ae298365e35fc9751ddd052b48057c1022eab3e764fc068fdcdc990c6d1d390f09f78a212591aa89e1632c9a57f237d0fbd38 WHIRLPOOL 658aa9666b5bf45a6c1ee4c9befb2511493d26b7945e7496dab3e41055adba7c6ae1879f0777fbcefd78755ab87d3b4262001743f7a2db81a2753ec4a3f1c515
+MISC metadata.xml 303 SHA256 c2b1cd56f7f6ede0086894cad490df68631b7dde83bcc8979ead63dbd55505da SHA512 8f66c2172d20eaf54fd19875d994e8aa96ef22a83868ade0c53af4789cda3fb5058b12b24932d44120237e5cedafff9e626f4d3b875821fc48f845677879d81f WHIRLPOOL 078c2e4033af1012742fb907b7317337ae019f7d123b0f5e0b277005ae4c380494398f84245cbd90ce78d8fa282b12ab9f92d8967b156f0c8a4bf17bfe9b9e04
diff --git a/dev-python/djangocms-picture/djangocms-picture-2.0.5.ebuild b/dev-python/djangocms-picture/djangocms-picture-2.0.5.ebuild
new file mode 100644
index 000000000000..b6c4dbec8630
--- /dev/null
+++ b/dev-python/djangocms-picture/djangocms-picture-2.0.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Picture plugin for django CMS"
+HOMEPAGE="https://pypi.python.org/pypi/djangocms-picture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/djangocms-attributes-field-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/django-filer-1.2.4[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+PDEPEND=">=dev-python/django-cms-3.2.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i 's/find_packages()/find_packages(exclude=["tests"])/g' "${S}/setup.py"
+ eapply_user
+}
diff --git a/dev-python/djangocms-picture/metadata.xml b/dev-python/djangocms-picture/metadata.xml
new file mode 100644
index 000000000000..e76677692df2
--- /dev/null
+++ b/dev-python/djangocms-picture/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>slis@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">djangocms-picture</remote-id>
+ </upstream>
+</pkgmetadata>