summaryrefslogtreecommitdiff
path: root/dev-python/dkimpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/dkimpy
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/dkimpy')
-rw-r--r--dev-python/dkimpy/Manifest4
-rw-r--r--dev-python/dkimpy/dkimpy-1.0.4.ebuild38
-rw-r--r--dev-python/dkimpy/metadata.xml34
3 files changed, 53 insertions, 23 deletions
diff --git a/dev-python/dkimpy/Manifest b/dev-python/dkimpy/Manifest
index 014dcc053a7e..0edd4515b6ba 100644
--- a/dev-python/dkimpy/Manifest
+++ b/dev-python/dkimpy/Manifest
@@ -1,3 +1,5 @@
DIST dkimpy-0.9.2.tar.gz 50263 BLAKE2B e18b1337699c1e843b4878cc84aa9988adaca475cd22b406b558c132a36761669c835dbb9718ba6c40fa5f78efe669d08c8517d6208f783399834737f4805671 SHA512 a1e7ac778f8cf0897793f296061ef67a6945b136db1a7aee18498ce33111d1a0d485b0ce32f52c22c0866be644065e000de57131301000a83a1b55b6a875bfce
+DIST dkimpy-1.0.4.tar.gz 59689 BLAKE2B ddbe24f3d98833260763eac65199dc282d4833f22adaf5495247c2198626da826d8e1b40767a7a85dd2fe62efe527d99e3c2bcbb838f1038e6ae65af1a60b686 SHA512 0c6b35f6658b11bee340cfe51eca03c301ee052ce602a326b4519bbe134cc7f7d816b8b58faf38bec53b71201bd57dcd1869dd4f3df942cbf2f49caca04cde34
EBUILD dkimpy-0.9.2.ebuild 489 BLAKE2B 49ccf54702fb4209edde655b4d9f24970faaa97bd55fb9739953c421bf17ebf01da7d7cb2b310ea8fe9935e909ddf0ca50003f92d8bb12f7d526b471155b7c0f SHA512 937d48be3116d4abb7fe2b957fadf07b03f66d1b3a1a1c9ee607475ce045e5ca6ce123a2aeb5d9a8305c8169ee3c16ae7283f274b24e18c579bc3d9e4b9e39f2
-MISC metadata.xml 1162 BLAKE2B 002d890c839d0fb8fc6b03368bccc69bf4e4136ad70fdb82e5f8e156cfe22bd774feece7fe522b78c400c332e4bcf95a7c52b81271879ec891329e1ed342d342 SHA512 3a496a88b0a666afc846f69be9a7819d513087cefd3541524c0d8aaef1d073071fd49a69b364938c649134878bc150d40840c03628e93f14f8bb001508395be5
+EBUILD dkimpy-1.0.4.ebuild 811 BLAKE2B 402c9e9dd19249c1e684ce3499a6c43b5733f8d14643831d4a1a1d4c481ae4b5d47ab9eb51c0ccad0cad0b728dd0af0813affbeeaa0984b1f278041ef7656829 SHA512 ac8741c77ed3c4a0978c8de959873cbfc53b5b44fc2474b5054e42dcdf04972cb9a4f3b0050c7e32abcea6392f1cb120b673d159a4741c2322664044cb32b585
+MISC metadata.xml 484 BLAKE2B 14c8de62e359754a4d1dda796cd4f41a216cc3a740bbea0e127bd08f9db82acfa616159beffbd7763f345e61b32152dc66417b1dd125a500d32ddaf71655ea5b SHA512 5290aa58fb15040115413a5eaa144a5c39071a9362f86b34c969b057821267ef978b90900d4d5e52b336c00927cda6878b679cb2d4c2a7f9b4f9dfa9ad425ed6
diff --git a/dev-python/dkimpy/dkimpy-1.0.4.ebuild b/dev-python/dkimpy/dkimpy-1.0.4.ebuild
new file mode 100644
index 000000000000..459673c351c6
--- /dev/null
+++ b/dev-python/dkimpy/dkimpy-1.0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="DKIM and ARC email signing and verification library"
+HOMEPAGE="https://launchpad.net/dkimpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/dnspython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+BDEPEND+="
+ test? (
+ dev-python/authres[${PYTHON_USEDEP}]
+ dev-python/pynacl[${PYTHON_USEDEP}]
+ )
+"
+
+pkg_postinst() {
+ elog "Optional dependencies:"
+ optfeature "ARC support" dev-python/authres
+ optfeature "ed25519 capability" dev-python/pynacl
+ optfeature "asyncio support" dev-python/aiodns
+}
diff --git a/dev-python/dkimpy/metadata.xml b/dev-python/dkimpy/metadata.xml
index 83c7605ab5ba..2249c703089a 100644
--- a/dev-python/dkimpy/metadata.xml
+++ b/dev-python/dkimpy/metadata.xml
@@ -1,26 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription lang="en">
- Python module that implements DKIM (DomainKeys Identified Mail) email
- signing and verification. It also provides helper scripts for command
- line signing and verification. As of version 0.6.0, it also supports
- the experimental Authenticated Received Chain (ARC) protocol.
-
- Originally developed by Greg Hewgill http://hewgill.com/pydkim/ - The
- code in this project has been modified and development work continued.
- This is now a fork of pydkim and we've renamed it dkimpy to avoid
- confusion. The original author of pydkim has confirmed he no longer
- intends to maintain it and supports this as its continuation.
-
- Current documentation is available online at
- https://gathman.org/pydkim/
-
- ARC is still in development. dkimpy 0.6.0 supports draft
- https://tools.ietf.org/html/draft-ietf-dmarc-arc-protocol-01 with the
- exception of requiring 1024 bit minimum key size (this matches the
- planned changes in the next update).
- </longdescription>
+ <maintainer type="person">
+ <email>ddenoncin@gmail.com</email>
+ <name>David Denoncin</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">dkimpy</remote-id>
+ <remote-id type="pypi">dkimpy</remote-id>
+ </upstream>
</pkgmetadata>
-