summaryrefslogtreecommitdiff
path: root/dev-python/dnspython/dnspython-2.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-17 11:37:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-17 11:37:14 +0000
commitf8deb4f754798d63fb6b82178452ee846df8475f (patch)
tree8f187327b54a42741f986268292e3096aadc4019 /dev-python/dnspython/dnspython-2.6.0.ebuild
parentc4a46526c2232ba00b0ccc97f2d2a30b0c6baea5 (diff)
gentoo auto-resync : 17:02:2024 - 11:37:14
Diffstat (limited to 'dev-python/dnspython/dnspython-2.6.0.ebuild')
-rw-r--r--dev-python/dnspython/dnspython-2.6.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/dnspython/dnspython-2.6.0.ebuild b/dev-python/dnspython/dnspython-2.6.0.ebuild
new file mode 100644
index 000000000000..fa76df91c401
--- /dev/null
+++ b/dev-python/dnspython/dnspython-2.6.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="
+ https://www.dnspython.org/
+ https://github.com/rthalley/dnspython/
+ https://pypi.org/project/dnspython/
+"
+SRC_URI="
+ https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="dnssec examples"
+
+RDEPEND="
+ dnssec? (
+ >=dev-python/cryptography-41[${PYTHON_USEDEP}]
+ )
+ >=dev-python/idna-2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/cryptography-41[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}