summaryrefslogtreecommitdiff
path: root/dev-python/dnspython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-21 08:09:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-21 08:09:25 +0000
commit5adb1b3ff590f0911922679849a7fdacc8b4f217 (patch)
tree8a471fe02dd3498487715d39f928b42017f24c99 /dev-python/dnspython
parentafcb9236a72cf602364c28b9bde6648e4a7f1ca5 (diff)
gentoo auto-resync : 21:01:2024 - 08:09:25
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest2
-rw-r--r--dev-python/dnspython/dnspython-2.5.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index b57f93db4d8e..c9f97fffc0f6 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,3 +1,5 @@
DIST dnspython-2.4.2.gh.tar.gz 357675 BLAKE2B ceb2f4a824a1c2b834401d2eb7943e62a5fb28a19be64cea8071d7e294d1a6aa80dc82266586d050fcb1c0eff881d9e139be335313d2098b6c3c6cf690f398ab SHA512 6a76331fc8bc282bb8ef61509317b1956bec6fb516a57409b1df38c8f5094e5ddfcaabc951f7678f1be75e735962c94f225b6e78eb4abe56b27e075180c62576
+DIST dnspython-2.5.0.gh.tar.gz 366093 BLAKE2B f8e3d8632a74b0421f7c77316dc80e01936277d701c282239ed60e79952755d34c673f15e19d4da812883e33d5f2cb54a8faa419185d8d198de923a2f3861095 SHA512 8ed207f9cee88dc1deb626d727c510dabace327586911e340df435c8cce5936efee51937b52881b4b4452d9c8c5bd903044bfef5a4effa95aaf05f24c0213b07
EBUILD dnspython-2.4.2.ebuild 1036 BLAKE2B 09065dc34e1d6c65eaa2efaeb7432a74ee004070a5e49ced70e2ad0aee9a7e38ef14decc18286410fa3aa2640c503d815e3c3fd870a2148a6376c0676130b6bd SHA512 dba146f266a31de5bace5606a4df9d7adce10cebf951fcb2e14d764216efaaed094f0a0b2ac2d2bd9dfbe7f837756789175629c5b251fe9ac72c2ec73f83388b
+EBUILD dnspython-2.5.0.ebuild 1027 BLAKE2B 0575a64e02ae1f60d17083e87b30b3a7a90735c2fcd0014c16a52662dd5dd5017ce683ba03c8d936bc9ea02c7529ca584612201fff2301a295c362c6d63a06e2 SHA512 3c8798e6fe0fa22fab1de512b4b2c5e4b46493598f0a0bc5bdd87a8a7a8ebd01bc8624728ed2a8b450aa844f626c439aaa85aff92e52ba2c41db2bafa5f5c13f
MISC metadata.xml 1709 BLAKE2B abd502753325fedca3f1ca94818258c9d1b82f88766f9e005b35b3e79aff71ca2efaf06188e73ea30830f80ec011cdf5c42df320130c9295e13d3c427a148f8c SHA512 8c25d579a4a2a7c5ff34c21643a1386a434545f6b9b465f4aa8e07f7da3aee203bbc0341e930ddb767af431f64e8024ddd6cc8513cfce862c5900da4637bb1c8
diff --git a/dev-python/dnspython/dnspython-2.5.0.ebuild b/dev-python/dnspython/dnspython-2.5.0.ebuild
new file mode 100644
index 000000000000..fa76df91c401
--- /dev/null
+++ b/dev-python/dnspython/dnspython-2.5.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="
+ https://www.dnspython.org/
+ https://github.com/rthalley/dnspython/
+ https://pypi.org/project/dnspython/
+"
+SRC_URI="
+ https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="dnssec examples"
+
+RDEPEND="
+ dnssec? (
+ >=dev-python/cryptography-41[${PYTHON_USEDEP}]
+ )
+ >=dev-python/idna-2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/cryptography-41[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}