summaryrefslogtreecommitdiff
path: root/dev-python/dnspython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-16 11:57:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-16 11:57:19 +0000
commit61f62e5edc868fc4ae3b92af397397ee5056578a (patch)
tree81261ca75a34aa85973eeb3cd828878c4e72bcee /dev-python/dnspython
parent433cb2e828d414c74b16d429f40d25e179b0a70f (diff)
gentoo auto-resync : 16:01:2023 - 11:57:19
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest2
-rw-r--r--dev-python/dnspython/dnspython-2.3.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index 8e4b4fd2f53c..97582c4a2f49 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,3 +1,5 @@
DIST dnspython-2.2.1.tar.gz 304861 BLAKE2B e6446b91579c6ec0a7266a354ceb58e2f881b55b7376648770ebc2c6104fd815214497516d305b75802e9211703d47a70d66745d872a43afb72f41e55a617652 SHA512 ec545468f604d6131f07259ca154c4f71d445d12c336ac1da0d2f025d6478ada76320a7235119312fed85da071ef309d2531e541d3c2340a50deaf3f4dd7b4eb
+DIST dnspython-2.3.0.gh.tar.gz 339222 BLAKE2B 1e1bfd1d716f5afce1ccc2e0f1fbb8e575e91619bc32f2c5067f6da4e01ea927dd0a1ed4c35e6c88d34de320befd833c9c17d060ea71918775c1f5f0121b61a8 SHA512 0bb4b41262a1d97b724e48b4dfb70f1fb544c18824e7d2bc2dcb8ef6c943c6c827ce753ae4ccb2ab37e95c8f5ff5d2f4853f238509f21e6299a445760c41e10e
EBUILD dnspython-2.2.1-r1.ebuild 1086 BLAKE2B a83956783877012b134c7cb20db4ccf30f603edacc6f8b34aedb56924764f098b5d4ccac5927a167d5fd581f5faaf4aa682283ba50c4a09acadc51cc5e9ff758 SHA512 d827ac2b7f6ff589ea941abcde83d84b577f0229dddc4c99c3cde4af76578eadaf75cfeeebf8559cdcdad2e22aad8ab17216a0098cf75a33ed2f0efe033c2b2b
+EBUILD dnspython-2.3.0.ebuild 1097 BLAKE2B 127c57d6ac90424b27bf91e3725084437e3fb8cdecb719ca53c48a1f1bf31f2d76ffc7696f077a176ed373d84e4e773efc4d150a7a5ce940a7454003498c622a SHA512 eb52ebdbd2074af69b4d4277f6078eff75999bbbf5fc76aa7be72749bf0b43b7de3ee5d7addfc5f995b662c1d6395b8406a16ce2b33d4a860430171a70e411e4
MISC metadata.xml 1651 BLAKE2B ea1ce5f9d27de56010f40b2187ac0b5876c27f41163e966689cb8958304c466011ebea0e5979c73b2ce14e6ed406833d01251982e43af945f868ab57dfdc848f SHA512 3d66dff8a832f935110f27e0f397457940de38a09e158bafa275872f96f1c6c5bb7fd1fd558610a8db64e2a7b9fb91cc6c744d3a7dc2eab3a19b85d526c2975a
diff --git a/dev-python/dnspython/dnspython-2.3.0.ebuild b/dev-python/dnspython/dnspython-2.3.0.ebuild
new file mode 100644
index 000000000000..3362a2edb297
--- /dev/null
+++ b/dev-python/dnspython/dnspython-2.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="
+ https://www.dnspython.org/
+ https://github.com/rthalley/dnspython/
+ https://pypi.org/project/dnspython/
+"
+SRC_URI="
+ https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="dnssec examples"
+
+RDEPEND="
+ dnssec? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ <dev-python/idna-4.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/network_avail/s:True:False:' \
+ tests/*.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -s
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}