summaryrefslogtreecommitdiff
path: root/dev-python/dnspython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/dnspython
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest3
-rw-r--r--dev-python/dnspython/dnspython-1.15.0-r1.ebuild40
-rw-r--r--dev-python/dnspython/metadata.xml27
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
new file mode 100644
index 000000000000..0356ad1f858c
--- /dev/null
+++ b/dev-python/dnspython/Manifest
@@ -0,0 +1,3 @@
+DIST dnspython-1.15.0.zip 252157 BLAKE2B 6766c1e69bc4225b08f3b1b3871fac2aba7ae707de5f16718798ce4d6846308500c5341f9ace1b48d3858ffc965a7295ee42cc2c35ff23ac38d71927dcaecfe9 SHA512 942f7cf083d1b0a9f03f040ceca194c38777f2e40862c388051986112b3f2a4a8426733ff46ec5a155319776e4a856412c3430b052b2f92f251f0e3260eb9bc1
+EBUILD dnspython-1.15.0-r1.ebuild 1035 BLAKE2B 799aaede1fb8078df7632674da6c6efa26edabeaa13e6fac1d41624edf27219e4b28bd54e3dd32429b92c856e040a05e3f05e88638a0320374105a86a242ab44 SHA512 c58f2eb758034ad0e7ee00e3e1ba1012870a624b6ec6f9f7e1d1f215fa75e3cc6c00783ee15cd58b7306a30de071b8caa1f36b824f015a8c8b3995c86f93dbb6
+MISC metadata.xml 1458 BLAKE2B 9a04546a3cb62f7ed6a72a8416e7f38aca15733a444970e84fe0134d0097eca4ae8fab9433f66196539de66a4b6b92103a4531f9248cf508a2e0f4d16c85c172 SHA512 40c86234936ba4f0c01a98266e74d49a80a8a48d4761b887ec84fe3ff9b534e7b6daf3c317d299b1333132a6025e49abf63884e7d6d0634c876dc74b470e0a7d
diff --git a/dev-python/dnspython/dnspython-1.15.0-r1.ebuild b/dev-python/dnspython/dnspython-1.15.0-r1.ebuild
new file mode 100644
index 000000000000..464b5c7c119c
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.15.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ https://pypi.org/project/dnspython/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples test"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ !dev-python/dnspython:py2
+ !dev-python/dnspython:py3"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip"
+
+# For testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
+ einfo "Testsuite passed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/dnspython/metadata.xml b/dev-python/dnspython/metadata.xml
new file mode 100644
index 000000000000..e990a706f75a
--- /dev/null
+++ b/dev-python/dnspython/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+dnspython is a DNS toolkit for Python. It supports almost all of the record
+types. It can be used for queries, zone transfers, and dynamic updates. It
+supports TSIG authenticated messages and EDNS0. dnspython provides both high
+and low level access to DNS. The high level classes perform queries for data
+of a given name, type, and class, and return an answer set. The low level
+classes allow direct manipulation of DNS zones, messages, names, and records.
+ </longdescription>
+ <longdescription lang="ja">
+DNSPythonはPython言語用のDNSツールキットです。ほとんどのレコード・タイプをサポー
+トします。クエリー、ゾーン・トランスファー、ダイナミック・アップデートができます
+。TSTGメッセージ認証とEDNS0をサポートします。DNSPythonは高水準でのアクセスと低水
+準でのアクセスの両方を提供します。高水準ではネーム、タイプ、クラスでクエリーを行
+い、その戻り値を使います。低水準はゾーン、メッセージ、ネーム、レコードを直接操作
+します。
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">dnspython</remote-id>
+ </upstream>
+</pkgmetadata>