summaryrefslogtreecommitdiff
path: root/dev-python/dockerpty/dockerpty-0.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/dockerpty/dockerpty-0.4.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/dockerpty/dockerpty-0.4.1.ebuild')
-rw-r--r--dev-python/dockerpty/dockerpty-0.4.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/dockerpty/dockerpty-0.4.1.ebuild b/dev-python/dockerpty/dockerpty-0.4.1.ebuild
new file mode 100644
index 000000000000..1068fac1b819
--- /dev/null
+++ b/dev-python/dockerpty/dockerpty-0.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python library to use the pseudo-tty of a docker container"
+HOMEPAGE="https://github.com/d11wtq/dockerpty"
+SRC_URI="https://github.com/d11wtq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/docker-py-0.7.0_rc2[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.5.2[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=">=dev-python/six-1.3.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ py.test tests || die "Tests failed under ${EPYTHON}"
+}